Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Been banging my head against the wall on this one for a while. I have an encrypted (via truecrypt) partition on a drive. In windows, I mount it locally and share it on my local network. I'm trying to do the same in Ubuntu 10.10 but am running into permission issues. The tc volume has funny permissions and I just can't seem to figure out a way to access it (unsecurely of course) over my network. Other non-tc volume shares work just fine.

To recap, I mount a truecrypt volume in Ubuntu and set up a samba share as normal. The share shows up on my local network but accessing it gives 'permission denied'. Mounting as a network drive using a password does not seem to work either.

Any insight would be greatly appreciated.

share|improve this question
add comment

1 Answer

Woohoo. Perhaps writing the question got me thinking about things more clearly but I figured out a method that works.

First edit your /etc/fuse.conf to allow other users by uncommenting the user_allow_other line at the bottom. (use gksu gedit /etc/fuse.conf)

Next you've got to mount the Truecrypt volume with read permissions for "other". Do that from the command line using:

truecrypt --fs-options="uid=1000,gid=1000,umask=0002" /dev/YourVol mount-point/

As long as you've got samba set up properly you are good to go.

share|improve this answer
    
Many thanks for this. Got it working with just the mount option to set the permissions. Didn't need to use gksu whatever that is. –  zuallauz Mar 9 '12 at 9:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.