Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Now I've really messed things up.

A long time ago, I installed Google Earth via a binary installer from Google (v5.1, I think).

Google now has version 6 available as a .DEB, so I decided to install that. However, that seems to have messed up both installations and now no matter what I do, I can't get Google Earth to run.

Here's what I do:

sudo apt-get purge google-earth-stable
sudo dpkg -i --force-overwrite google-earth-stable_current_amd64.deb

Which I thought would work... but when I run google-earth, I get:

/usr/bin/google-earth: 43: ./googleearth-bin: not found

How can I get it installed now?

share|improve this question
    
I think deb files are just archives - open it with archive manager and see where the "googleearth-bin" should be located and see if it's on your system (possibly not available on the $PATH)? –  Scaine Feb 22 '11 at 20:29
add comment

4 Answers

up vote 4 down vote accepted

Try with this tutorial :

install-google-earth-6-in-ubuntu-linux.html

hope it help

share|improve this answer
    
It worked! Thank you so much! –  Nathan Osman Feb 22 '11 at 21:29
add comment

Go to this page and click on the big blue button that says "Download Google Earth 6", this should give you the option of installing Google Earth as a .deb. Install it like you would any other .deb

share|improve this answer
    
That's what I did... and I've got the error above in my question. –  Nathan Osman Feb 22 '11 at 20:11
    
oh my bad... lol guess I am of no use then –  TheX Feb 22 '11 at 20:19
add comment

I downloaded the 32-bit version, then right clicked on it and choose "Extract Here" in nautilus. That shows me the folder structure that would be installed if I installed the deb file. It seems that the "googleearth-bin" file should be in /opt/google/earth/free.

I guess you'll need to check whether that exists on your system. If not, perhaps the binary install has changed the permissions on that file in a way that breaks overwriting from the deb? Not sure how that's possible given that you have to sudo to install a deb.

Google Earth file structure

It looks like the /usr/bin/googleearth is just a shortcut to that file too, not a script, so it's likely that there's something wrong in the /opt directory I mentioned above.

File properties

I guess you'll be best served by deleting the files/folders in the deb, then trying the re-install afresh?

share|improve this answer
    
Well, I completely removed the package and verified that /opt/google/earth was deleted... and it was. –  Nathan Osman Feb 22 '11 at 21:01
    
It gets weirder: when I run /opt/google/earth/free/googleearth-bin, I get an error: bash: ./googleearth-bin: No such file or directory even though the file exists and I can stat it. –  Nathan Osman Feb 22 '11 at 21:04
add comment

First I'd go about uninstalling everything related to google-earth you can find.

The 5.1 binary installer defaults to /opt/google-earth as the install location, and also places a link in /usr/local/bin called googleearth. If you delete those two things, you should have successfully uninstalled the old version.

Next I'd do what you've already mentioned (again):

sudo apt-get purge google-earth*

Finally, use the locate command to see if there are some lingering files somewhere. This gets various permutations:

locate -i --regex "google.*earth"

Delete anything that shows up there (unless you're sure it's unrelated to the app). You may have a .googleearth directory in your user directory, which you could probably leave but maybe rename or delete it too if you still have problems.

Once you've cleaned everything out, then go install the .deb package again.

Good luck!

share|improve this answer
    
Well, actually, sudo apt-get purge google-earth* doesn't work because the package is named google-earth-stable. –  Nathan Osman Feb 22 '11 at 21:09
    
apt-get handles * as a wild-character, so google-earth* should include google-earth-stable. That said, there's also the fact that on my machine the 5.1 .deb is called googleearth, so google-earth* won't catch everything! –  Jack Senechal Feb 22 '11 at 21:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.