Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am fairly new at all this.

I have set up a home server using an old laptop and Ubuntu 12.04 to stream media to my LG TV through their DLNA system called MediaLink. This is being done through Plex Media Server. I am also using a Windows Vista PC to access the file system on the server to backup data and copy media onto the server for use in Plex.

I am running Samba which I have set up through the GUI interface. I am sharing two directories on the network and have mapped these on the Vista PC. For each of these directories, I have allowed access to everyone through Samba.

In Samba I have set up the Server Security Settings as 'authentification mode - user', 'encrypt passwords - yes' and no guest account.

For each of the directories I have applied read / write permissions to the owner, group and others through Nuatilus by right clicking on the drectories and setting permissions through the properties.

The problem I am having is that anything I add to the directories or change in the directories using my Vista PC doesn't have the same permissions as the directory. In fact, I can then not access these files through the server (using VNC) and Plex cannot play these files as they are locked and only accessible be the Vista PC.

It seems I can use Nuatilus to apply the correct permissions after the fact, but I want this to happen automatically.

I have read a number of articles detailing fixes through the terminal and through the smb.conf file by setting the user profiles to 777, 076, etc but don't really know what I'm doing with this and don't want to break things.

Any help would be much appreciated. Step-by-step instructions please.

share|improve this question

1 Answer 1

Since I cannot comment to ask for your smb.conf I will just try my best to answer your question. First of all I have not tried these and have only found them through research.

  1. Open a terminal (Ctrl+Alt+T) and edit your smb.conf by typing in: gksu /etc/samba/smb.conf
  2. In that file, find your different shares and make them look like this (keep the name of your share and the path the same):

    [someshare]
        path = /somewhere
        read only = No
        writeable = Yes
        guest ok = Yes
        create mask = 0777
        security mask = 0777
        directory mask = 0777
        force create mode = 0777
        directory security mask = 0777
        force directory mode = 0777
    
  3. Save the file (Ctrl+S) and close the window.

  4. Finally run sudo service smbd restart to restart your samba server and it should now be working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.