Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting very slow write speeds (<1MB) with RAID 1 and RAID 0 (striping and mirroring). The read speeds are sufficiently fast but writing is very slow. At first I thought it was just poor performance under RAID 1 but it is occuring with RAID 0 (although not as bad).

I noticed that compared to when Ubuntu was on a virtual machine there are multiple instances of kdmflush process running using most of my IO (detected using iotop).

Does anyone have any suggestions as to what could be causing this?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I assume you are using software RAID.

Is your disk synchronization still going on? You can check that by running

cat /proc/mdstat

If not, you may have problems with (physical) disks. At first, check dmesg output, and try to find disk related error messages. If there is nothing, you can use

sudo smartctl /dev/sda
sudo smartctl /dev/sdb

(or whatever your disks are, you can see that for example from /proc/mdstat).

smartctl also supports running disk tests:

sudo smartctl -t short /dev/sda
share|improve this answer
    
I've done SMART Testing using smartctl already on the drives and they both passed. There is no synchronization still happening (I'd hope not as I gave them both 4 days) I'll check the dmesg to see if there is anything else. –  dko Feb 22 '11 at 21:09

Something is very wrong here. Either a disk is going bad or there's a configuration issue you're not aware of or have discarded as a variable. On the software RAID side you can try to take turns, kicking one disk out of the array, and then benchmark the RAID. Reassemble, sync, and repeat with the other member. If they perform around the same then you've got a deeper problem. kdmflush is just deferred work getting done by device mapper.

Running iotop -a is interesting since it shows the accumulation of I/O traffic since iotop started. That should help you track down where the bulk of the traffic is coming from.

So are you running lvm too? I don't think MD uses that process. If you've got some snapshots lying around that you've never deleted that could be dragging you down. Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.