Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell XPS M1330 running Kubuntu 10.04.

When I resume from suspend,

  1. I get the blank lockscreen I set up, but I can't move my mouse, it's in the upper left hand corner of the screen.
  2. The computer takes some time, some toaster notifications flash (above the screensaver for a second, then hiding)
  3. I hear the "welcome back" tones.
  4. I can move my mouse and log in.

This whole process can take anywhere between 15 and 45 seconds. Is there a way to figure out what is causing this delay, and to hopefully resolve it?

share|improve this question
    
Is this only happening with the Dell or with other hardware too? –  txwikinger Jul 29 '10 at 4:34
    
I've only seen it happen on my laptop, but S/R doesn't work at all on the desky. –  lfaraone Jul 29 '10 at 4:51
add comment

3 Answers

up vote 3 down vote accepted

Depending on the speed of your drive, 'paging in' the contents of running application's memory from disk can take a considerable amount of time when the system wakes up.

This also depends on what the kernel has 'paged out' (to swap) prior to going into the suspended state. You'll probably also notice that even once you can move the mouse around, going back to certain applications produces another slight pause while the drive activity light comes on for a few moments.

I see the same behavior on my netbook, more prominently when I have 30+ tabs open in Chrome prior to suspending.

share|improve this answer
    
Cool. Anything I can do about it? –  lfaraone Jul 29 '10 at 13:53
    
You can try setting /proc/sys/vm/swappiness to 0, which may make paging back applications a little easier once the system has fully woken up. This just affects running application responsiveness once that happens, however, not really the speed at which the system finally becomes responsive as a whole. –  Tim Post Jul 29 '10 at 15:01
add comment

This is not dependent on Dell hardware, as it also happened on my Lenovo X201. Apparently, this is an issue caused by timeouts in the networking stack (e.g. an unconnected eth0 waiting for a DHCP answer). For me, it was fixed by removing the "auto eth0" line from /etc/network/interfaces, as described here: https://bugs.launchpad.net/ubuntu/+bug/217846/comments/23

share|improve this answer
add comment

You could profile the backend KDE components causing the symptom. Start by using the pm-utils hooks.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.