Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm following the instructions on using the desktop installer to get Ubuntu on to my nexus 7, but it gets stuck on first boot on 'Applying changes' > Noting disappearance of ubiquity. When I click on 'Details' it's stuck on 'Purging configuration files for ubiquity ...'. It's sat there for an hour so far.

I have switched usb cable and reinstalled stock android (successfully) and tried again as suggested on the wiki page.

I have also tried the manual installing instructions and get a FAILED (remote: (InvalidSize)) error.

Any ideas where i'm doing wrong?

share|improve this question

I had exactly the same issue. I got round it by installing the image from this link:


I had to use an OTG cable and USB keyboard to do the installation (if I tried to configure the wifi then the keyboard stopped functioning - so I installed without specifying the wifi).

Once booted I found I could not apt-get update, the work around was to type:

cd /var/lib/apt
sudo rm -fr lists
sudo mkdir lists
sudo mkdir lists/partial

Then I could apt-get update and upgrade.

I hope this helps!


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.