Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have done the regionset thing, but the drive doesnt find a dvd when I do. I have added the css file I have tried manually mounting the drive and get

Failed to mount '/dev/sr0' to '/media/apt/' E: Unable to locate any package files, perhaps this is not a Debian Disc or the wrong architecture?

I have a brand new hp probook 4430s. I wiped windows and installed ubuntu. Some dvd's have played, and some havent and there seems no rhyme or reason to play or not. (I still have a list of dvd_css's in the .dvdcss file.)

I have read pages and pages of helps trying to find the answer and as yet no answer has fixed my problem

    *-cdrom
         description: DVD-RAM writer
         product: DVD RW AD-7711H
         vendor: hp
         physical id: 0.0.0
         bus info: scsi@1:0.0.0
         logical name: /dev/cdrom2
         logical name: /dev/cdrw2
         logical name: /dev/dvd2
         logical name: /dev/dvdrw2
         logical name: /dev/sr0
         version: 1.82
         capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
         configuration: ansiversion=5 status=nodisc

There was a disk (RV with robin williams) in the drive at the time. Using VLC, I set it to open /dev/dvd2 (as thats the address of the drive it seems) instead of the default /dev/dvd and got this error:

Playback failure:
DVDRead could not open the disc "/dev/dvd2".
Your input can't be opened:
VLC is unable to open the MRL 'dvd:///dev/dvd2'. Check the log for details.
share|improve this question
    
what happens when you try the default /dev/dvd? –  Elder Geek Jun 25 at 15:09
    
Some DVDs just won't read in some drives. –  dobey Jul 9 at 14:43

1 Answer 1

Examine the offending disk to insure it has no deep scratches that would interfere with the lasers ability to read it. Once you are certain you have a good disk:

Open VLC, hold the CTRL key and tap D

This setting works fine for me. /dev/sr0 also works for me.

vlc-dev/dvd

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.