Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Basically I was trying to resize my drive since I was low on disk space for the Ubuntu OS using a WUBI of Ubuntu 12.10(I believe that or 12.04). But my computer shut down in the process. Now when I try to access my personal account the application bar(left side) doesn't show up, the status bar(top) is gone, but the terminal works. I have tried to go through using cd but it says I don't have permission, after using sudo it still doesn't work. I'm sure the data is still there since in the terminal I used ls and it shows all the files even after the shutdown. I tried downloading and using gparted but the recover data thing came up with an error. Oddly enough when I access the guest account everything seems normal except I don't have root privileges(So I can't alter anything from there).

When I tried to access firefox through the terminal nothing came up and only more error messages popped up than usual. When I used any other application it wouldn't pop up with anything only showing more errors and one on my spotify application that said this process isn't supposed to happen.

I know there's no restore point option in ubuntu after googling any possible solutions out there. I am very new to Ubuntu so if anyone could help me, please!

share|improve this question
    
What were you resizing? The partition (which won't work for Wubi) or the Wubi virtual disk? Maybe you're just low on space. What does df -h say from the terminal? –  bcbc Mar 30 '13 at 4:11
    
Is it possible that you can receive pictures? Otherwise I've used up luke 100% of the space available. –  linkwaker10 Mar 30 '13 at 19:52
    
I mean the results say i've used up all 11.6 GB –  linkwaker10 Mar 30 '13 at 20:17

1 Answer 1

up vote 1 down vote accepted

If you've used up all the space, then that would explain why it doesn't boot. I usually ensure there's at least 500MB free.

Your options are:

  1. Backup files from Windows using Ext2Read (the latest is 2.2, but I heard 2.1 works better). You run it and point it at the file \ubuntu\disks\root.disk and then you get readonly access to your data.

  2. Boot from a live CD and then you can a) delete files to make space, b) backup files or c) resize the Wubi virtual disk.

If you do Step 2. then you can get the Wubi install booting again. If you just do Step 1. then you can reinstall a normal dual-boot (non-Wubi) once you've backed up your data, or you can migrate from the root.disk to a normal dual boot (but you have to create the partitions yourself before migrating).

If you need help with one of the options, comment and I'll flesh out my answer for your needs or direct you to another, relevant thread.

share|improve this answer
    
Thank you So SO much!! I'm working on this right now, hopefully I get all that I need from Ext2Read and then get the OS working correctly again. Again thank you! –  linkwaker10 Mar 30 '13 at 23:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.