Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was able to set up the terminal to expand the whole monitor width but I would like for it to stay on the top of the screen even if I go to another workspace. If I hit F12 to drop it down when I am on a different workspace, it brings me back to the workspace I opened the terminal in and then puts the terminal window on the bottom of the monitor screen.

Below you will see my config:

[global_config]
  enabled_plugins = LaunchpadCodeURLHandler, APTURLHandler, LaunchpadBugURLHandler
  hide_from_taskbar = True
  always_on_top = True
  tab_position = bottom
  sticky = True
[keybindings]
  hide_window = F12
[profiles]
  [[default]]
    background_darkness = 0.93
    palette = "#000000:#cc0000:#4e9a06:#c4a000:#3465a4:#75507b:#06989a:#d3d7cf:#555753:#ef2929:#8ae234:#fce94f:#729fcf:#ad7fa8:#34e2e2:#eeeeec"
    background_type = transparent
    foreground_color = "#00ff00"
[layouts]
  [[default]]
    [[[child0]]]
      position = 0:24
      type = Window
      order = 0
      parent = ""
      size = 1700, 464
    [[[terminal3]]]
      profile = default
      type = Terminal
      order = 1
      parent = child0
    [[[terminal2]]]
      profile = default
      type = Terminal
      order = 0
      parent = child0
[plugins]

Here is what happens via screen shot. I was on workspace 1, then switched to workspace 2, and hit F12. As you can see, I was brought back to WS 1 with the terminal at the bottom.

Before workspace change

After workspace change and hitting F12

share|improve this question
    
There is a setting in preferences to 'show on all workspaces'; that option is present in the 12.04 default version. That seems to work for me. Now when you go to a different workspace you can press f12 and stay on that workspace. –  user76204 Apr 2 '13 at 23:31
    
@Mik I have that set but it doesn't stop it from occurring. –  dustin Apr 2 '13 at 23:31
1  
I'm sure you're probably set on the Terminator Terminal, but I thought I'd mention Guake. It works the way you describe. –  Kupiakos Apr 2 '13 at 23:43
    
Interestingly, the fact that the setting I mentioned works on Xfce and not on your system (Unity/compiz) probably means that the terminator workspaces setting doesn't take account of the compiz viewports system properly. Perhaps you could somehow use ccsm to tweak the behaviour of terminator. –  user76204 Apr 2 '13 at 23:45
1  
I'm not greatly experienced with ccsm, but this general question might be helpful regarding window rules. –  user76204 Apr 2 '13 at 23:55
show 5 more comments

2 Answers 2

up vote 1 down vote accepted

Switching from Ubuntu to Xubuntu fixes this issue.

share|improve this answer
add comment

You can set easily define Terminator's appearance and behaviour by right-clicking anywhere in an active window and them choosing "Preferences". Play around a little and you'll surely find a satisfying setting.

share|improve this answer
1  
that doesn't address saving layouts. If you go into preferences and then layouts, it doesn't say save current layout. It doesn't even ask you to modify it. Also, your "answer" doesn't address the terminals behaviour between workspace which isn't in preferences either. –  dustin Mar 29 '13 at 23:18
    
I don't think it is possible to have the app open on all workspaces but you can take the window with you to another workspace by pressing alt+tab+ctrl+arrows. –  speter Mar 30 '13 at 11:07
    
I am not saying open on every workspace. When I minimize the app with F12, move to another workspace, and then hit F12 again, I am brought back to the first workspace with the terminal at the bottom. Very annoying. –  dustin Mar 30 '13 at 15:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.