Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Each time my 3G Vodafone k4505 Pen get's mounted by the system, I get a icon on my desktop. I would like to NOT have that icon each time I connect this 3g usb pen.

How can we accomplish this?

Thanks in advance, MEM

share|improve this question

1 Answer 1

up vote 4 down vote accepted
  1. Press Alt-F2 and enter gconf-editor.
  2. Navigate to apps/nautilus/desktop.
  3. Deselect volumes_visible.

gconf-editor

If you want your other volumes to be visible, you will have to add them manually:

  1. Right click on desktop and click 'Create Launcher...'
  2. Change the type to 'Location'
  3. Change the name to suit you.
  4. Browse for the volume.
  5. Change the icon to the 'block device' icon at /usr/share/icons/YOUR_THEME/devices/48/block-device.svg
  6. Click OK.

launcher

share|improve this answer
    
That will disable all other volumes that we may want as well right? –  MEM Aug 20 '10 at 18:20
    
Yes, you will have to manually add the ones you want. –  dv3500ea Aug 20 '10 at 18:22
    
Amazing :) You absolutely rock. Second Ubuntu day here, but feeling the power already. :) Thanks. –  MEM Aug 20 '10 at 18:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.