Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Using Ubuntu-Raring I connect via 'Files/Connect-to-server': ssh://root@myhost:mysshport/

connection works ok, but I am connected to '/root' on the target system and can not reach the filesystem root (I can not do a 'cd /' via the UI)

How can I specify my connect string so that the mount point is the filesystem root? (Note: when I do the same under Win via Bitvise client I get a selector to chose '/' or '/root' so there does not seem to be a problem on the server side.)

Thanks a lot for any hints!

share|improve this question

1 Answer 1

nautilus always connects to the user directory of the server, and I did not figure a way out to connect directly to "/" , this is a working workaround.

If you specify a Path when connecting,

enter image description here

You can go back in the filesystem of the Server (or, for me, my iPhone). See that you got the option to go back in the top.

enter image description here

Then you can click on "[user] on [the server IP]" (for me, "root at 192.168.178.22"), you get then to the root of the Server.

enter image description here

EDIT: I just found out if you cannot see the bar on the top to go back to root, you can press ALT+ArrowUP and you will see it.

Tested on Ubuntu 14.04 LTS with GNOME nautilus 3.10.1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.