Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is a Toshiba Satellite A215-S7422 running Ubuntu 12.04. The command

cat /proc/asound/card0/codec#* | grep Codec

gives the result

Codec: LSI ID 1040
Codec: Realtek ALC268

My headphones work, but speakers do not. I have tried several different model options in /etc/modprobe.d/alsa-base, but I'm not sure if I got the right one since I couldn't figure out how to find my sound card in the Alsa documentation. I've downloaded and compiled the most recent alsa drivers, as suggested here. When headphones are not plugged in the Sound preferences screen shows Speakers, which changes to and from Headphones appropriately, so the system seems to be recognizing the internal sound card and speakers fine. The speaker is not muted in the system notification bar or in alsamixer. What else should I be doing to troubleshoot/fix the issue?

If alsa is not the easiest way to do this, I'm open to answers that get my speakers working while maintaining the functionality of my headphones jack.

share|improve this question
1  
Do you specifically need to be using Alsa? –  david6 Mar 29 '13 at 22:05
    
That's a good point. I'm not really sure what it would entail to not be using alsa in ubuntu. If you have suggestions for me to try that involve other... sound managers? Is that what it is? Go ahead! I'll edit my question to reflect the need better. –  VruNix Mar 29 '13 at 22:21
    
I have used Alsa (some time ago), mostly in 10.04 and 8.04. I can probably find some old notes. –  david6 Mar 29 '13 at 23:02

2 Answers 2

As used for Ubuntu 10.04 (Jul-2010)


Sound: Internal Speaker (desktop, mono)

Find 'master' label: (for card 0, OR change to 1, 2, etc.)

amixer -c 0 | grep Master

(look for 'mono' control, for internal speaker)

Simple mixer control 'Master',0

Simple mixer control 'Master Mono',0

Read back settings: (using label from previous)

amixer -c 0 sget 'Master Mono',0

Simple mixer control 'Master Mono',0 Capabilities: pvolume

pvolume-joined pswitch pswitch-joined penum Playback channels: Mono

Limits: Playback 0 - 31 Mono: Playback 0 [0%] [-46.50dB] [off]

Set to enable, neutral gain: (eg. +-0dB) (NOTE: "0dB" is case sensitive!)

amixer -c 0 sset 'Master Mono',0 0dB,0dB unmute

Verify settings: (optional, but recommended)

amixer -c 0 sget 'Master Mono',0

Simple mixer control 'Master Mono',0 Capabilities: pvolume

pvolume-joined pswitch pswitch-joined penum Playback channels: Mono

Limits: Playback 0 - 31 Mono: Playback 31 [100%] [0.00dB] [on]

Save settings: (non volatile)

sudo alsactl store

UPDATE

Find correct label (for left/right inbuilt speakers):

amixer -c 0 | grep Simple

for example (on my desktop, Ubuntu 12.04 LTS)

Simple mixer control 'Master',0
Simple mixer control 'Headphone',0
Simple mixer control 'Speaker',0
Simple mixer control 'PCM',0
Simple mixer control 'Line',0
Simple mixer control 'Mic',0
Simple mixer control 'Mic Boost',0
Simple mixer control 'Capture',0
Simple mixer control 'Capture',1
Simple mixer control 'Auto-Mute Mode',0
Simple mixer control 'Input Source',0
Simple mixer control 'Input Source',1
share|improve this answer
    
Sorry, no dice. The laptop internal speakers have a left and a right, so there's no 'Master Mono' label, just the 'Master'. I checked using sget, and 'Master' was already set to 0dB and turned on. I set it with sset just in case I was missing something, and no improvement was caused. –  VruNix Mar 30 '13 at 6:40

Go to sound setting and change the output to your inbuilt speakers. You'll have to change it back to headphones every time you connect one. I'm trying to come up with a permanent solution but this works for me for the time being.

share|improve this answer
    
Also not a helpful answer. As I explained in the question text, the sound preferences already properly show 'Speaker' as the output type (not headphones) when headphones are not plugged in. –  VruNix Jul 31 '13 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.