Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install libflann1.7-dev I have removed libflann1, so now I have no libflann at all. Next I ran:

sudo apt-get install libflann1.7

which installed fine, I then try to install libflann1.7-dev and get the following error:

The following packages have unmet dependencies.
 libflann1.7-dev : Depends: libflann1.7 (= 1.7.1-1+maverick5) but 1.7.1-4 is to be installed
E: Unable to correct problems, you have held broken packages.

I have no idea why, as I have just installed libflann1.7 but apparently I have version 1.7.1.4 and libflann1.7-dev needs 1.7.1.1?

Thanks

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The fact I see a mention of maverick in there suggests to me that you have another repository in there. This usually happens when you have a crusty old PPA gumming things up with its own versions.

To double-check this I ran:

$ apt-cache depends libflann-dev 
libflann-dev
  Depends: libflann1.7
  Conflicts: libflann-dev:i386

No mention of a crusty maverick version :)

If you run apt-cache policy libflann-dev you will be able to see what versions are available to you, including which repos they're coming from. Spot the dodgy one and nuke it. In my case, here's what I see:

$ apt-cache policy libflann-dev 
libflann-dev:
  Installed: (none)
  Candidate: 1.7.1-4
  Version table:
     1.7.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/universe amd64 Packages
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.