Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Asus Zenbook UX32VD laptop, using nVidia Optimus technology and having two graphics cards: one from Intel and one from nVidia.

I've been running Ubuntu 13.04 happily for a month now using bumblebee's optirun successfully. Today optirun suddenly didn't work:

➜  ~  optirun -vv glxgears
[  529.776886] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  529.777578] [INFO]Configured driver: nvidia-304
[  529.777895] [DEBUG]optirun version 3.1 starting...
[  529.777928] [DEBUG]Active configuration:
[  529.777938] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  529.777948] [DEBUG] X display: :8
[  529.777957] [DEBUG] LD_LIBRARY_PATH: 
[  529.777966] [DEBUG] Socket path: /var/run/bumblebee.socket
[  529.777975] [DEBUG] Accel/display bridge: auto
[  529.777984] [DEBUG] VGL Compression: proxy
[  529.778056] [DEBUG]Using auto-detected bridge virtualgl    
[  529.827706] [INFO]Response: No - error: Could not load GPU driver

[  529.827756] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  529.827777] [DEBUG]Socket closed.
[  529.827828] [ERROR]Aborting because fallback start is disabled.
[  529.827847] [DEBUG]Killing all remaining processes.

My bumblebee.conf contains the following:

[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
KeepUnusedXServer=false
ServerGroup=bumblebee
TurnCardOffAtExit=false
NoEcoModeOverride=false
Driver=nvidia-304

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-304
Module=nvidia-304

PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-304:/usr/lib32/nvidia-304
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-304/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

And xorg.conf.nvidia:

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
EndSection

Section "Device"
    Identifier  "Device1"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "UseEDID" "true"
    Option "ConnectedMonitor" "DFP"
EndSection

lspci lists the nVidia card:

01:00.0 3D controller: NVIDIA Corporation Device 1140 (rev a1)
  Subsystem: ASUSTeK Computer Inc. Device 1507
  Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
  Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
  Latency: 0, Cache Line Size: 64 bytes
  Interrupt: pin A routed to IRQ 16
  Region 0: Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
  Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
  Region 3: Memory at f0000000 (64-bit, prefetchable) [size=32M]
  Region 5: I/O ports at e000 [size=128]
  Expansion ROM at f7000000 [disabled] [size=512K]
  Capabilities: [60] Power Management version 3
    Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
  Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000  Data: 0000
  Capabilities: [78] Express (v2) Endpoint, MSI 00
    DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
      ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
      RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
      MaxPayload 256 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <512ns, L1 <4us
      ClockPM+ Surprise- LLActRep- BwNot-
    LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
      ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x8, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Range AB, TimeoutDis+
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
       Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
       Compliance De-emphasis: -6dB
    LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
       EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
  Capabilities: [b4] Vendor Specific Information: Len=14 <?>
  Capabilities: [100 v1] Virtual Channel
    Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
    Arb:    Fixed- WRR32- WRR64- WRR128-
    Ctrl:   ArbSelect=Fixed
    Status: InProgress-
    VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
      Arb:  Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
      Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
      Status:   NegoPending- InProgress-
  Capabilities: [128 v1] Power Budgeting <?>
  Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
  Kernel driver in use: nvidia

And all the required modules should be loaded:

➜  ~  lsmod |grep nvidia
nvidia              11300875  0 
➜  ~  lsmod |grep bbswitch
bbswitch               13611  0 

I don't have any specific X configuration in /etc/X11/xorg.conf.d that's sometimes a problem with Bumblebee.

Here's a list with dpkg -l nvidia:

ii  bumblebee-nvidia                               3.1-2~raringppa2                     amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  nvidia-304                                     304.84-0ubuntu2                      amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
rc  nvidia-304-updates                             304.84-0ubuntu2                      amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-current                                 304.84-0ubuntu2                      amd64        Transitional package for nvidia-current
rc  nvidia-experimental-310                        310.14-0ubuntu2                      amd64        Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library
rc  nvidia-settings                                304.51-0ubuntu2                      amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-settings-304                            304.64-0ubuntu1                      amd64        Tool for configuring the NVIDIA graphics driver

Even dmesg says the bbswitch is on and working properly:

[    5.746576] bbswitch: version 0.6
[    5.746583] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    5.746588] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    5.746699] bbswitch: detected an Optimus _DSM function
[    5.762030] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[    5.763705] bbswitch: disabling discrete graphics

I've tried to use nvidia-304, nvidia-304-updates and nvidia-experimental-310. None of them work.

share|improve this question

closed as off topic by Web-E, Eliah Kagan, Luis Mar 29 '13 at 12:55

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
welcome to askubuntu. Questions regarding ubuntu +1 are considered off topic here.(FAQ) Please file a bug report. –  Web-E Mar 29 '13 at 12:01
    
2  
Ok, this helped to fix the problem: github.com/Bumblebee-Project/Bumblebee/issues/… –  pimeys Mar 29 '13 at 14:11