Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometimes different applications crashes, and the system notifies me that crashed application uses third party library (libz) and suggests trying without it.

I can always reproduce it by exporting PNG file to JPEG format in Gimp:

(Full size screenshot)

When I first experienced the issue I had libz 1.2.5 installed in the system, then I updated it to 1.2.7, but the issue persists.

I don't know when and what this library was installed for.

I googled a lot for this, but hasn't find anything useful, so it looks like this is special case.

===========UPDATE 7.04.2013===========

After looking into strace output I don't think that my issue is related to zlib. So I'm changing the question title

Here is strace gimp output (launcher icons size = 36, "Radiance" Gnome theme)

futex(0x15b3434, FUTEX_WAKE_OP_PRIVATE, 1, 1, 0x15b3430, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_GT, 1}) = 1
futex(0x15b0fb0, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x1c4a560, FUTEX_WAKE_PRIVATE, 1) = 1
lstat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/usr/share/icons/Humanity/devices/16/drive-harddisk.svg", {st_mode=S_IFREG|0644, st_size=7338, ...}) = 0
open("/usr/share/icons/Humanity/devices/16/drive-harddisk.svg", O_RDONLY) = 19
fstat(19, {st_mode=S_IFREG|0644, st_size=7338, ...}) = 0
read(19, "<?xml version=\"1.0\" encoding=\"UT"..., 65536) = 7338
read(19, "", 65536)                     = 0
close(19)                               = 0
write(2, "\n(gimp:19027): Gtk-CRITICAL **: "..., 106
(gimp:19027): Gtk-CRITICAL **: IA__gtk_tree_model_get: assertion `GTK_IS_TREE_MODEL (tree_model)' failed
) = 106
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

(script-fu:19034): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
+++ killed by SIGSEGV (core dumped) +++
Segmentation fault (core dumped)

I've read several threads with similar issues discussion, and those issues were related to gnome theme, icons, unity launcher icons size etc... I tried to play with those packages reinstalling, settings but nothing helped me.

=====================================

So can anybody suggest me please what I should check and try?

# file /usr/local/lib/libz.so.1.2.7
/usr/local/lib/libz.so.1.2.7: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=0x4b579c2bcc6eb41c0dc9c473e8298e5249fedbe1, not stripped
# md5sum /usr/local/lib/libz.so.1.2.7
65ffc4f5f7b943cd569ba2136cd49f7b  /usr/local/lib/libz.so.1.2.7
# ls -lh /usr/local/lib/libz.so.1.2.7
-rwxr-xr-x 1 root root 99K лют  9 19:54 /usr/local/lib/libz.so.1.2.7

System: Ubuntu 12.04 x64_86 Gimp 2.6.12

Thank you in advance.

share|improve this question
    
Usually libs are installed in /usr/lib{32} and not in /usr/local/lib. Didn't you installed it manually? If you don't need a specific recent version, there is available on the repos an older version of zlib (v1.2.3.4). –  Salem Apr 7 '13 at 10:54
    
You are right Salem. I mentioned in the description that I installed this library for some reason I can't remember, probably attempting to solve this issue. I've removed /usr/local/lib/libz.so.1 symlink and as per strace right library (1.2.3.4) is used now by Gimp. Unfortunately that didn't fix the issue. –  gumkins Apr 7 '13 at 11:40

1 Answer 1

up vote 1 down vote accepted

Answering my question by myself.

I think that at the beginning my question was little misleading.

The system reported me that the crash could happen because of third party library used by Gimp (/usr/local/lib/libz.so.1.2.7).

I removed /usr/local/lib/libz.so.1 symlink to /usr/local/lib/libz.so.1.2.7 and traced with strace that default library is used

access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/local/lib/libz.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/tls/x86_64/libz.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib/x86_64-linux-gnu/tls/x86_64", 0x7fff82fc2f00) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/tls/libz.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib/x86_64-linux-gnu/tls", 0x7fff82fc2f00) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/x86_64/libz.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib/x86_64-linux-gnu/x86_64", 0x7fff82fc2f00) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/libz.so.1", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0P \0\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0644, st_size=92720, ...}) = 0
mmap(NULL, 2187824, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f99b8b30000
mprotect(0x7f99b8b46000, 2093056, PROT_NONE) = 0
mmap(0x7f99b8d45000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x15000) = 0x7f99b8d45000
close(3)

That didn't fix the issue.

But after some additional research I think I've found related bug-report.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.