Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just tried to update Ubuntu from Precise to Quantal from the Update Manager, and after it finished, I can get to the Grub screen just fine, and select Ubuntu, but no dice on the load.

When 12.10 tries to load, all get the following error message, which quickly disappears:

gpio_ich: failed to claim resource 0

After this, my screen goes blank, with a blinking cursor in the upper left hand corner that has sat there for literally 15 minutes before I get fed up and hit the power button.

I have run boot repair, to no avail. I have also boot up Linux in recovery mode and tried to repair broken packages. Also, no dice. The latest report from my Boot Repair log is here.

I have been running Ubuntu since 10.04, and this is the first upgrade issue I have had. Does anyone here have a clue what went wrong?

I have never had to do this before, so it feels kinda weird. Also, worst case scenario: If I download the 12.10 ISO and install from that, can I do an upgrade on my system without losing files? I've never had to do this before, so never had to find out or ask.

share|improve this question
add comment

1 Answer 1

This might work by booting into the terminal

sudo apt-get update && sudo apt-get upgrade

sudo apt-get clean

sudo apt-get dist-upgrade

sudo apt-get clean

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.