Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when I try to remote desktop to the server from another ubuntu machine using the remote desktop viewer, it asks me to enter the password, which I do, then the viewer pane just goes black. When I come back and look at my server it is saying that the password keyring no longer matches the password used to login to the machine please reenter the password...and when I type in the password it doesnt take it, it just keeps popping back up saying the same message over and over.

I found a thread explaining to go to System-->Preferences-->Passwords & Encryptions and right click on the keyring and click Set as Default.

I did that and the problem persists...I tried changing the password but it told me that my original password was incorrect (even though it is the password I use to login and provide root authentication when asked)

so I deleted the keyring in hopes of adding a new one but there is no place in gui to add a new can I add a new one through command line?

if so - how?

share|improve this question
up vote 1 down vote accepted

I found what I was looking for within the passwords and keyrings section under preferences: I totally missed the menu bar at the top with file, edit, blah blah blah. Anyways, I went to file, new and created a new keyring. After that I could connect perfectly fine with no issues. So creating a new keyring (or changing the password) fixed my problem.

share|improve this answer
As a further note, once I created a new keyring with my login password, I set it as default (and deleted the old one, but that is strictly optional). – Josh Glover Aug 16 '11 at 6:53

Maybe you are looking for this dialog in System -> Preferences -> Remote Desktop

VNC Password

where you can define a password for remote desktop access (maximum 8 characters). Also avoid special characters to minimize authentification problems.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.