Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When I run sudo apt-get wine1.5 I get this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.26-0ubuntu1) but it is not installable
           Recommends: gnome-exe-thumbnailer but it is not going to be installed or
                       kde-runtime but it is not going to be installed
           Recommends: fonts-droid but it is not going to be installed
           Recommends: ttf-mscorefonts-installer but it is not going to be installed
           Recommends: fonts-horai-umefont but it is not going to be installed
           Recommends: fonts-unfonts-core but it is not going to be installed
           Recommends: winbind but it is not going to be installed
           Recommends: winetricks but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

echo "foreign-architecture i386" | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch
sudo chmod 644 /etc/dpkg/dpkg.cfg.d/multiarch

Same error.


sudo aptitude install wine1.5 gettext:i386-

The output is different then the first time because it was already run.

Couldn't find any package whose name or description matched "gettext:i386"
Couldn't find any package whose name or description matched "gettext:i386"
The following NEW packages will be installed:
  libcapi20-3{a} libmpg123-0{a} libodbc1{a} libopenal-data{a} libopenal1{a} libosmesa6{a} libtiff4{a} odbcinst{a} odbcinst1debian2{a} unixodbc{a} wine-gecko1.9{a} wine-mono0.0.8{a}
  wine1.5{b} wine1.5-amd64{a}
The following packages are RECOMMENDED but will NOT be installed:
  fonts-droid fonts-horai-umefont fonts-unfonts-core gnome-exe-thumbnailer kde-runtime ttf-mscorefonts-installer winbind winetricks
0 packages upgraded, 14 newly installed, 0 to remove and 2 not upgraded.
Need to get 92.2 MB of archives. After unpacking 196 MB will be used.
The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.26-0ubuntu1) which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     wine1.5 [Not Installed]
2)     wine1.5-amd64 [Not Installed]

     Leave the following dependencies unresolved:
3)     wine-mono0.0.8 recommends wine1.5
4)     wine-gecko1.9 recommends wine1.5-amd64


Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
share|improve this question

marked as duplicate by Braiam, Stephen Myall, Seth, Mitch, guntbert Aug 29 '13 at 17:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
See also Why is Wine not installable on my system? –  Eliah Kagan Aug 29 '13 at 18:43
add comment

1 Answer 1

When I have these problems I usually run

sudo apt-get clean (to fix broken packages)

sudo apt-get dist-upgrade (to force install a package)

share|improve this answer
    
Doesn't work... –  Runemoro Mar 29 '13 at 15:07
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.