Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I open synaptic via launcher on gnome-panel, it opens and asks me for the password but if I enter the password, it says its wrong even though the password is correct and it used to work OK few days ago. If I open synaptic via terminal using sudo synaptic then it opens OK without any problem.

share|improve this question
    
What command does the launcher use to launch Synaptic? – Oxwivi Feb 22 '11 at 12:59
    
gksu --description /usr/share/applications/synaptic.desktop /usr/sbin/synaptic – HSS Feb 22 '11 at 13:03
    
I have solved it. Thanks for your concerns though. – HSS Feb 22 '11 at 13:03
up vote 2 down vote accepted

Ok, I have found whats wrong. I found the answer on ubuntuforums. Here is what to do.

press alt+f2 and run gconf-editor now go to apps->gksu and tick the sudo-mode checkbox and thats it.

share|improve this answer
    
Thanks, I was having the same issue. – jcollum Nov 24 '11 at 2:45

The answer above is correct. But if the launcher that launches your synaptic is pkexec, you can change it by editing the synaptic.desktop on /usr/share/applications folder and change the Exec= synaptic-pkexec command to Exec= gksu synaptic %u then save it. By pressing ALT + F2, run gconf-editor , go to apps and gksu mark sudo-mode. That may do.

You can also see my answers " in this link "

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.