Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.04 and I have some weird issues with emerald not starting sometimes, leaving me "chromeless" windows. I can, of course then start emerald with emerald --replace > /dev/null 2>&1 & \ disown $!, but it'd be really nice to just make sure it starts no matter what.

Currently, emerald is being started by compiz, I believe, as I set emerald as my decorator using CompizConfig Settings Manager:

CCSM Screenshot

Is there a better way to do this so that we can ensure that it starts every time?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

I think the preferred way to make Compiz use Emerald for the window decorations is to create the file ~/.config/compiz/compiz-manager and add the following line:

USE_EMERALD=yes

The script /usr/bin/compiz-decorator looks for the config file

$XDG_CONFIG_HOME/compiz/compiz-manager

($XDG_CONFIG_HOME is ~/.config by default) for user specific preferences.

So set the command for the Window Decorations module back to /usr/bin/compiz-decorator and create/edit the config file as described above.

share|improve this answer
    
Awesome! I had no clue about that file, really helpful. I seem to be getting a better framerate as well. It works and I'm definitely running Emerald, and time will tell if I run into any 'emerald not starting' problems :) Thanks! –  Naftuli Tzvi Kay Feb 24 '11 at 1:10
add comment

A while back I had issues with Compiz either not starting, or crashing out, leaving everything unmanaged. At first I created a launcher on the desktop (pointing to compiz --replace) but I soon got tired of that.

The long term "solution", while still a hack, was to create a little inline script to run on boot in the Startup Applications (in System -> Preferences) that ran:

bash -c "sleep 2; compiz --replace"

So I suggest you do something similar with emerald. I don't think you need all that redirection fluff you have on the end. You could probably get more intelligent about it (looking for an existing emerald process before loading it), but if you don't mind a bit of window flicker on boot, there's no harm in replacing a running instance with a new one.

share|improve this answer
add comment

You can use Compiz Fusion Icon which can be easily installed by dropping sudo apt-get install fusion-icon in a terminal. After that, find the fusion-icon in the System Tools menu and you will have several choices in the panel's fusion icon, which includes but not limits to: Select Window Decorator.

Right click the fusion icon and choose your prefered window decorator, window manager and a few other features. Then select "Reload Window Manager" and your monitor or windows may flicker.

Don't worry, it will take just a moment to reload your options and after that you can close the fusion Icon. The options should persist this time.

A screenshot is placed here to illustrate.

Good luck!

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.