Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I hope someone has figured this out because I've spent days with google trying to track down the solution.

I got fed up with microsoft Win XP and 7 and decided to try ubuntu 12.04 on a spare laptop (Dell E6400). Everything was going fine - I got it connected to my Livebox router using wifi, I could see and access the external hard drive connected to the Livebox USB and I could connect a Canon Pixma iP5000 usb printer locally to the computer.

The wheels came off when I tried to connect ubuntu 12.04 LTS computer to the printer (Canon Pixma iP5000) which is now connected to the USB on the Livebox. I have not had any problems connecting to this networked printer using a Win XP machine over the wifi.

I tried 3 ways to use the add printer over the network using the tool in Ubuntu 12.04 LTS:

  1. Find Network Printer

    • I searched for the printer (192.168.1.1 - the livebox IP address) and the tool quickly found "My Gateway Printer" which it connected as ipp://192.168.1.1:631/printers/gateway-usb-printer.
    • I used the driver finder to install Canon PIXMA iP5000-CUPS+Gutenprint V5.2.8-pre1. This is the same driver that works when the printer is attached to the computer via USB connection.

    • When I tried to print a test page, I get an indication Idle - Printing page 1, 20%

    I investigated using CUPS tool in Firefox. The CUPS 1.5.3 tool shows an error message: aborted unable to add document to print job.

  2. App Socket/HP Jet Direct

    • I entered host 192.168.1.1 port 9100. The tool sets up a connection socket:/192.168.1.1:9100 and uses the same print driver in (1) above.

    When I print a test page, I get a message processing - the printer is busy. Nothing ever happens.

  3. Windows Printer via SAMBA The tool creates a connection "smb:///192.168.1.1%3A631" and I again use the same printer driver in (1) above.

    When I print a test page, I get a message Processing - unable to connect to CIFS host, will retry in 60 seconds. The CUPS tool indicates Connection failed: NT_STATUS_BAD_NETWORK_NAME.

Can someone help me figure out what is going wrong here? I'd love to get this printer working over the network as the the basis of my project is to create ubuntu driven laptop that I can use to print and share files with my other computers over the livebox wifi network.

I'd appreciate specific instructions to get the printer (connected by USB to a Livebox wifi router) to connect over the wifi network to my laptop.

Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.