Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Didn't use to happen. Now happens with any upload of csv data, regardless of content (and it isn't Chinese!).

enter image description here

I checked

cat /etc/default/locale
LANG="en_US.UTF-8"

My language settings are all English

enter image description here

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Somehow my character set had got changed from "Unicode" to "Unicode (UTF-8). Changing it back completely fixed this issue

See screenshots:

Before:enter image description here

After:enter image description here

share|improve this answer

your character set in import page is wrong and should be "UNICOE (UTF-8)"; you have,more probably as a "UNICODE (UTF-16), which is wrong!

when you try import an csv file, you should pay attention to "character set" of the import.

when you click on CSV file to open it, Libre Office open the first import PAGE and ask you how do you what to import it.

Above of this window you see the option "character set; the front of that you see a of different option of setting font as a cascade menu; you should change it and choose "Unicode (UTF-8)".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.