Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

hello i am new to ubuntu and i have been trying to download wine, mp3 media players readers, and VLC. However every single time i try to download something this message pops p and closes the download it is really ennoying as ubuntu is useless without this working properly =( here is the message:

The following packages have unmet dependencies:

vlc: Depends: vlc-nox (= 2.0.5-0ubuntu0.12.10.1) but 2.0.5-0ubuntu0.12.10.1 is to be installed
     Depends: libavcodec-extra-53 (>= 6:0.8.4) but 6:0.8.5ubuntu0.12.10.1 is to be installed
     Depends: libavutil-extra-51 (>= 6:0.8.4) but 6:0.8.5ubuntu0.12.10.1 is to be installed
     Depends: libc6 (>= 2.15) but 2.15-0ubuntu20.1 is to be installed
     Depends: libfreetype6 (>= 2.2.1) but 2.4.10-0ubuntu1.1 is to be installed
     Depends: libgcc1 (>= 1:4.1.1) but 1:4.7.2-2ubuntu1 is to be installed
     Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
     Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
     Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
     Depends: libstdc++6 (>= 4.6) but 4.7.2-2ubuntu1 is to be installed
     Depends: libtar0 but it is not going to be installed
     Depends: libxcb-keysyms1 (>= 0.3.9) but it is not going to be installed
     Depends: zlib1g (>= 1:1.2.3.3) but 1:1.2.7.dfsg-13 is to be installed

i really need help plz

share|improve this question

marked as duplicate by Luis Mar 28 '13 at 15:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

up vote 0 down vote accepted

I think it is a problem of missing dependencies, try updating your ubuntu first. Or the program needs the latest version of ubuntu. Which version do you use?

share|improve this answer
    
ubuntu 12.10 their are no updates available it says =( –  Loic Mar 28 '13 at 14:43
    
but what do you mean by dependencies? and if they do miss were can i get it? –  Loic Mar 28 '13 at 14:51
    
try this in the terminal: sudo rm /var/lib/apt/lists/lock sudo apt-get update sudo apt-get dist-upgrade –  Sabeer Sulaiman Mar 28 '13 at 16:14
    
Enter them one line at a time. After opening terminal by pressing Ctrl+Alt+T –  Sabeer Sulaiman Mar 28 '13 at 16:18

Try:

sudo apt-get -f install

sudo apt-get clean

sudo apt-get update

check this tutorial: https://help.ubuntu.com/community/AptGet/Howto

Regards.

share|improve this answer
    
it doesnt work =// thx for helping –  Loic Mar 28 '13 at 14:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.