Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problems playing videos on my Ubuntu 10.10 machine. The video FREEZES every 20-25 seconds, while I could still hear the audio. I use Totem Movie Player (GStreamer) & have nVidia on-board graphics card & AMD DualCore processor.

After some 5-10 seconds, the videos resume skipping the hung portion. But, I can hear the audio of that part! I've tried it with SMPlayer (GUI), VLC & Kaffeine. But, the same problem...

I recently uninstalled the nVidia drivers and since then, not even for a second, no video hung! So, I thought its the problem with the proprietary nVidia drivers. But, since its uninstalled, I'm not able to get the desired desktop resolution & effects. So, is there any way I can work it out?

share|improve this question
1  
I would check the situation out with another player. Eg mplayer is great, especially because it's mainly has CLI interface (though it has got GUI too). So try to use mplayer to play your video from terminal, and check the output of mplayer, what it prints there. Usually it gives more information you can use as diagnostics. I have multiple machines equipped with nVidia cards (but on-board ones) with the proprietary driver with a much weaker machine (old single core AMD CPU) but still, I haven't got this kind of problem. By the way, what happens after freeze? Does it continue after a while? –  LGB Feb 21 '11 at 19:49
    
Yeah, after some 5-10 seconds, the videos resumes skipping the hung portion. But, I can hear the audio of that part! I've tried it with SMPlayer (GUI), VLC & Kaffeine. But, the same problem... –  Chandan Feb 21 '11 at 20:08
1  
I would suggest mplayer (command line version, from terminal) because you may see more related messages about the problem. You can also run command top in terminal while playing back to see if there is some kind of CPU-hungry happening during playback. I would also check the kernel log (or output of command dmesg), I had some kind of resource conflict in the past and kernel complained about it, which I could see at least ... –  LGB Feb 21 '11 at 20:12
    
Did you check the temperature of the video card since you said it is onboard one. In many cases (At least for laptops) nvidia does not handle so well temperature, specially because of the space it has to cool off and the space it has for the heat it generates. –  Luis Alvarado Feb 21 '11 at 22:02

2 Answers 2

I've had similar problems with HD videos. Under mplayer, vlc, smplayer, totem, etc. it would consume 100% CPU and choke the video.

I've used good old xine and it works perfectly, thou it's not very user friendly ;)

share|improve this answer
up vote 0 down vote accepted

I think I found this problem addressed! I re-installed the nVidia drivers and the I disabled the "Sync to VBlank" option in CompizConfig Settings Manager (General > Display Options). Thank you all :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.