Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi i am new to Ubuntu (12.10) x64 Trying to forward ports for gameserver on my pc (Lineage II) Ports are opened in UFW Ports are opened in my Router Even if i disable UFW others still cant login to gameserver Tried most [Terminal] commands to forward ports still wont open I have the server opened which should make ports liste and they should appear to be open in sites like canyouseeme.ogr

Also tried some commands to open them in 'iptables' im so confused help

share|improve this question
    
Could you specify your network configuration? Is the Ubuntu machine your gameserver or your router? Or even something entirely else? –  André Stannek Mar 27 '13 at 21:45
    
Ye i am behind D-Link DIR-501 router, the ubuntu machine is the gameserver host, using static IP adress, –  user144870 Mar 27 '13 at 21:48
    
What does your Ubuntu machine do? Why do you wnt to forward ports on it? –  André Stannek Mar 27 '13 at 21:50
    
the ubuntu machine is the gameserver host, using static IP adress, –  user144870 Mar 27 '13 at 21:52
    
Then you don't need port forwarding on it. You just need to forward ports to it on your router. It's possible you messed up your network configuration while trying to do so. –  André Stannek Mar 27 '13 at 21:53

1 Answer 1

Please try the next workaround, after which and depending on your results, this answer may be deleted or improved. Thank you. I know this is not a forum but I provide this as an answer because of it works for me when setting up a WAN Game Server for Team Fortress 2 and it -indeed- does an excellent work.

First of all you need to install firestarter if haven't yet. Please drop sudo apt-get install firestarter in a terminal, provide your password and wait for the install to finish.

Next, let's run firestarter with administrative privileges by dropping gksudo firestarter in the terminal. After which we'll be asked for our user password in GUI. Then the firestarter window will appear, as shown in the next screenshot:

enter image description here

Let's clic the "Policy" Tab in order to add the proper ports or port lists that your game needs by right clicking on the second list (Allow service/Port/For) and choose "Add Rule" as shown in the next screenshot:

enter image description here

We'll see the "Add new inbound rule" in which we'll fill the data fields with the proper values in order to allow the port's calls hit the computer's ports.

enter image description here

The service's ports will be added to the list, after which you can reach your game server with no difficulty.

If you are experiencing some kind of issue, you can also temporally stop the Firewall in the top side of the "Status" Tab or via Menu "Firewall" option "Stop Firewall" (Ctrl+P also does the trick). This way you can check if your router is dropping the external petitions to your computer, after which you can solve your computer's ports issue.

Please let us know how are you managing this issue in order to modify/delete this question if doesn't work for you.

Good luck!

share|improve this answer
    
When i type 'gksudo firestarter' and type my pwd, some error appears (Firestarter error) Failed to open the system log. –  user144870 Mar 28 '13 at 11:00
    
did you try turning off your firewall via firestarter? Please inform. Thank you. –  Geppettvs D'Constanzo Mar 28 '13 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.