Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since Ubuntu 12.10 I have an error with the video card. My graphics card is "Intel HD graphics". The screen is distorted and sometimes there appear error messages.

enter image description here Because Ubuntu does not recognize the graphics card, I installed mesa-utils. Now appears that I am using Intel ® Sandy Bridge desktop, but the errors are still on.

enter image description here


I have installed Ubuntu 12.10 once again and this time I've made ​​no updates. Now there are no more errors. The problem must be due to the updates. Because I have to do about 300 updates, it will be difficult to pick out the faulty one.


With Synaptic I made updates stepwise and have now localized the faulty package. Incorrectly could be one of the following packages:

Commit Log for Sat Mar 30 12:25:05 2013

Die folgenden Pakete wurden entfernt: (The following packages were removed:)
libdrm-intel1:i386
libdrm-nouveau2:i386
libdrm-radeon1:i386
libdrm2:i386
libgl1-mesa-dri:i386
libgl1-mesa-glx:i386
libglu1-mesa:i386
playonlinux
wine
wine1.4
wine1.4-amd64
wine1.4-common
wine1.4-i386:i386

Die folgenden Pakete wurden aktualisiert:(The following packages have been updated:)
alsa-base (1.0.25+dfsg-0ubuntu3) to 1.0.25+dfsg-0ubuntu3.1
app-install-data-partner (12.12.10) to 12.12.10.1
apport (2.6.1-0ubuntu3) to 2.6.1-0ubuntu10
apport-gtk (2.6.1-0ubuntu3) to 2.6.1-0ubuntu10
apt (0.9.7.5ubuntu5) to 0.9.7.5ubuntu5.4
dmsetup (2:1.02.74-4ubuntu1) to 2:1.02.74-4ubuntu1.1
libcairo-gobject2 (1.12.2-1ubuntu2.2) to 1.12.4-0ubuntu0~quantal15.2
libcairo2 (1.12.2-1ubuntu2.2) to 1.12.4-0ubuntu0~quantal15.2
libdevmapper-event1.02.1 (2:1.02.74-4ubuntu1) to 2:1.02.74-4ubuntu1.1
libdevmapper1.02.1 (2:1.02.74-4ubuntu1) to 2:1.02.74-4ubuntu1.1
libdrm-intel1 (2.4.39-0ubuntu1) to 2.4.40-0ubuntu0~quantal5.2
libdrm-nouveau1a (2.4.39-0ubuntu1) to 2.4.40-0ubuntu0~quantal5.2
libdrm-nouveau2 (2.4.39-0ubuntu1) to 2.4.40-0ubuntu0~quantal5.2
libdrm-radeon1 (2.4.39-0ubuntu1) to 2.4.40-0ubuntu0~quantal5.2
libdrm2 (2.4.39-0ubuntu1) to 2.4.40-0ubuntu0~quantal5.2
libkms1 (2.4.39-0ubuntu1) to 2.4.40-0ubuntu0~quantal5.2
libva1 (1.0.15-4build1) to 1.1.0-0ubuntu0~quantal5.1
linux-image-generic (3.5.0.17.19) to 3.5.0.26.32
linux-libc-dev (3.5.0-17.28) to 3.5.0-26.42
ubuntu-drivers-common (1:0.2.71) to 1:0.2.71.1
xserver-xorg-video-intel (2:2.20.9-0ubuntu2) to 2:2.20.12-0ubuntu0~quantal5.1

Die folgenden Pakete wurden installiert:(The following packages were installed:)
linux-image-3.5.0-26-generic (3.5.0-26.42)

share|improve this question
    
Could you put some translations there? –  Frederik Spang Mar 30 '13 at 12:38
    
I have same problem with 12.10. Problem in kernel update. I use grub to loading ubuntu with 3.5.0-17 generic kernel after all updates and graphics works fine. –  user147010 Apr 5 '13 at 12:35

2 Answers 2

Try to:

sudo apt-get install linux-source ia32-libs mesa-utils
share|improve this answer
    
I get the following errror: The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-multiarch E: Unable to correct problems, you have held broken packages. –  Vincent Mar 30 '13 at 14:08
up vote 2 down vote accepted

I've removed the following packages and now it works.

linux-image-3.5.0-26-generic (3.5.0-26.42)  
linux-image-extra-3.5.0-26-generic (3.5.0-26.42)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.