Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu 12.10 was working fine, until a week ago when a software update was installed. Now, every two minutes, the computer hangs for a couple of seconds, and then an error message pops up saying "System program problem detected." Upon click "Show details", it shows that this is a problem with a file named apport-gpu-error-intel.py in /usr/share/apport/. How can I stop this from happening?

share|improve this question
    
Only mine's not a "false GPU hang"; it's real, it hangs for at least 2 seconds, and then displays the error window, and it's getting more frequent. –  user1730404 Mar 27 '13 at 20:36
    
I am also facing the same problem. The problem arised when I was using netbeans. So quite possibly it is related to java programs. I hope I dont need to completely format my system and start over again.! –  neo1691 Apr 4 '13 at 4:39

2 Answers 2

I've recently had the same problem on Ubuntu 12.04LTS. It appears this confirmed regression bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1140716 affecting Sandy Bridge Intel Processors (e.g. my i5-2410M with onboard-graphics).

I used the synaptic packager manager to remove the package xserver-xorg-core-lts-quantal and install the package xserver-xorg-core 2:1.11.4-0ubuntu10.12.

Also removed xserver-xorg-video-intel-lts-quantal and installed xserver-xorg-video-intel 2:2.17.0-1ubuntu4.3.

So far, this workaround seems to have solved the problem.

share|improve this answer

I also have this issue and I know I need to replace my thermal paste on my i7 and ATI/AMD GPU. I think I have my ATI turned off and so I think I'm just using my intel one. I recently cleaned out the fluff in my laptops heatsink. I had been meaning to clean it out for a while and my system froze and the GPU dialogue came up the next time I restarted. My laptop had also just been a bit wet from rain.

I opened it and cleaned the heatsink etc looking for any water, I didn't find any but I cleared all sorts of dust out.

My test will be after I've replaced the thermal paste as there should be no hardware/heat issues.

I've never had heat issues with my Sony Vaio, previously, I had an AMD HP which would get quite hot but was ok, there are many HPs with heat issues, especially the GPU. The chip does not directly touch the heatsink as there is a thermal pad. The GPU temp is not monitored and so it gets too hot and eventually stresses the solder joints underneath and they fracture causing screen flickering etc at moderate temperatures. This is fixed by heating up the chip enough to melt the solder properly and then adding aluminium foil or extra copper to the heatsink etc to get proper heat conduction.

So my point is that while it may be a software bug, it could be an indication of a hardware issue, I have killed my flash plugin and not experienced the hang warning for a few days now as I either suspend or hibernate my system for the last few days so the plugin generally stays killed and my fan is not going full on like it was before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.