Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried this on two different USB keyboards - both of which work fine on a different computer running Windows XP.

For some reason, the numerical keypad doesn't work probably immediately after booting up - neither the numbers work, nor the 'home' commands and so on that you can use with the numlock off. It doesn't make a difference whether I press numlock on or off - the keypad doesn't work correctly no matter what state this is in.

However, once I've booted the machine I can disconnect/reconnect the USB connector for the keyboard, and it will work exactly as expected.

I'm running Gnome on Ubuntu 10.04.

The only other USB devices connected is a mouse - and I've experienced no problems with that.

This is a direct connection to the box (not via an external USB hub)

share|improve this question

2 Answers 2

There is a Numlock button on your keyboard that activate the numerical keypad, if not activated the numerical keypad is used to move into documents (there should be arrows on the keys). On Windows XP this button is activated by default at startup, on Ubuntu it isn't. Just press the Numlock button after startup.

If it is a problem for you, then here is how to fix it :
https://help.ubuntu.com/community/NumLock

share|improve this answer
    
sry - didn't make it clear in my original question that pressing numlock doesn't make a difference. –  HorusKol Feb 21 '11 at 4:40
    
does selecting your keyboard model from preferences > keyboard make any difference? –  Allan Feb 21 '11 at 13:06
    
The problem has cleared after applying an update some time since I last responded in here... not entirely sure when, since I'd gotten into a habit of disconnecting/reconnecting the USB plug once I'd logged in, so I don't know which update... –  HorusKol Apr 4 '11 at 23:19

Already tried this one?

System > Settings > Keyboard > Mouse > disable steer mouse with keyboard

Helped me.

share|improve this answer
1  
I guess you mean 'System > Preferences > Keyboard > Mouse Keys' ? The move mouse pointer with numpad option was disabled - but I don't think this was the problem because I wasn't moving the mouse, and the problem cleared by reinserting the keyboard USB connector. That said, this is no longer a problem anyway - some update in March seems to have fixed it. –  HorusKol Oct 24 '11 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.