Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried every single possible way of installing the server now, I've read every how to available and I still can't get it to work. Please let me know in which step I do wrong. I'm using ubuntu 10.10. I will mainly be referring to the following how-to, but also this, and this one.

  • First I add the ppa
  • Install Freenx
  • Download the special Freenx package as stated in the howto, fix ownership - install it
  • Create custom SSH key
  • Copy the file /var/lib/nxserver/home/.ssh/client.id_dsa.key to the client and import it in nomachine (windows 7 x64)
  • Check that both the user I will be logging in with and the user nx is in AllowedUsers in the /etc/ssh/sshd_config file
  • Check the port that ssh is listening on
  • Login through nomachine with my regular user account in ubuntu

I always receive the message "authentication failed for [user]" when I try to log in. And I can't see the user "nx" which is said to be created during installation when I look under System->Administration->"Users & Groups". Can anyone please enlighten me if there is any step that I miss or have misunderstood?

Thank you very much!

(Or is there an easier way of enabling remote desktop that it can be used with a windows machine? I prefer not using VNC because I was hoping of being able to get better performance than that. And when I tried using XRDP I only received a black screen on the client.)

share|improve this question
    
One note, it looks like the correct property for sshd_config is AllowUsers, NOT AllowedUsers. I have hosed a half dozen ssh logins now using the wrong property name. My bad, but you might want to update that in your question. –  the0ther Dec 3 '11 at 23:42
    
i struggled with this all day, finally got it working. i am on ubuntu 10.04. the final step which allowed me to login was to enable challenge/response auth in sshd_config, i also allowed cleartext authorization. now just need to find out which one is required. –  the0ther Dec 4 '11 at 0:03
    
i have set PasswordAuthentication to no, so it looks like it only requires ChallengeResponseAuthentication to be turned on. –  the0ther Dec 4 '11 at 2:56
    
Thanks, for your reply the0ther! Hopefully this information will help many others :) –  Niklas Dec 5 '11 at 8:03
add comment

2 Answers

up vote 1 down vote accepted

First of all, the nx user is a system user (id less than 1000) so he is not visible in System->Administration->"Users & Groups", you should see him in /etc/passwd.

Next, I use freenx server without custom ssh key, so I suggest to make it to work without the added complication of custom key. I restore my security using the firewall to deny access to non desired clients.

share|improve this answer
    
Ok, I will try that when I get home. Is NX really the best method for Remote Desktops? –  Niklas Feb 21 '11 at 22:25
    
I don't know why it works now but didn't before, I recently made a fresh install on the server and this time it works perfectly, even though I haven't done anything different :/ –  Niklas Mar 3 '11 at 21:49
add comment

teamveawer 6 (teamviewer.com/en/download/index.aspx) or Haguichi (only for Linux OS) (haguichi.net/download) + Hamachi 2 (secure.logmein.com/US/labs) remember if you choose to used the second one installing first hamachi2 and then haguichi.

share|improve this answer
    
I'm sorry but that was not at all what I was asking for :/ –  Niklas Aug 10 '11 at 7:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.