Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I want to execute a script (I already marked it as executable), a text editor opens the script. If I want to choose an app from the list, the system suggests me editors, browsers, etc (not even a terminal). If I am looking for apps online (via Nautilus), all I get are text editors as well.

So the only way is that I open scripts via terminal. But why can't I just double click on them and hit "Run" in the window which pops up?

Thanks for your help!

I found a solution:

Open nautilus - > Preferences -> Behaviour -> Run executable text files when they are opened.

share|improve this question
    
bro, ubuntu is linux and has diferent shell than windows, and really can not recognize exe file as windows do. try with installing wine. –  Dimitris Theodoridis Mar 27 '13 at 13:36
    
@DimitrisTheodoridis I am very aware of that. And I am referring to apps which I specifically downloaded for Ubuntu. –  nikercan Mar 27 '13 at 13:38
    
please explain i didnt understand well what you trying to tell me? –  Dimitris Theodoridis Mar 27 '13 at 13:43
    
@DimitrisTheodoridis As an example: I downloaded Tor bundle, inside the folder, there is a script called "start-tor-browser". If I double-click on the script, the problem occurs which I described in my post. –  nikercan Mar 27 '13 at 13:46
    
i realy dont know what kind of scripts you are dealing with and dont know what is really tor bundle, i can just tell you to open system settings, open details page and you have on left, overwiev, default applications or whatever it was, and check your settings there. if is not there sorry i cannot help you this time, sorry please. but check first there. –  Dimitris Theodoridis Mar 27 '13 at 13:53

1 Answer 1

up vote 2 down vote accepted

Check your Nautilus settings. I use the German localisation, so be aware that the real English names might be different. Open the file browser (Nautilus). In its Edit menu open the settings dialogue. On the behaviour tab there are check boxes on what to do with executable scripts, letting you choose whether you want to show them, run them, or want to be prompted every time.

share|improve this answer
    
Although I already found the solution and wrote it in my post, you get the reputation you deserved ;) –  nikercan Mar 27 '13 at 14:10
    
Oh, sorry. I haven't seen that you edited your post. –  soulsource Mar 27 '13 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.