Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After follow this tutorial, I cannot lauch Sublime Text from command line... how can I fix this?

share|improve this question
up vote 26 down vote accepted

After follow that tutorial and face the problem reported, i googled about and realized that I forgot to create a symbolic link...

sudo ln -s /opt/sublime/sublime_text /usr/bin/subl

Now the problem is solved :)

share|improve this answer
    
I think it would be better to use /usr/local/bin instead of /usr/bin. – lev Jan 26 '15 at 9:17
2  
Do not do this with current versions of ST3 ... its already baked in – Scott Stensland Oct 17 '15 at 5:10
    
Did not occur for me using ST3, had to manually link. No command line options were available otherwise. – gnomed Apr 28 at 18:01

For recent versions of Ubuntu and Sublime Text 3, I'm adding a symlink like this:

sudo ln -s /opt/sublime_text/sublime_text /usr/local/bin/subl

Then I can execute it from terminal like subl myFile.php.

share|improve this answer
2  
+1 for using /usr/local/bin instead of /usr/bin. – lev Jan 26 '15 at 9:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.