Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a serious issue with MBR.

Initially got Windows 7 Up on my machine. I shrinked the active partition to create space for installing ubuntu. I formatted the new available space. Now i simply cannot boot to my Windows 7. So, plugged into Ubuntu LIVE USB drive, tried to access partitions and it says:

Unable to mount System: Adding read ACL for uid 999 to `/media/ubuntu' failed: Operation not supported

Didn't loose hope, so tried Boot-Repair, Now simply stuck at FreeDos screen at bootup

Please find Boot Info Below:

http://paste.ubuntu.com/5652026/

Any Help much appreciated! Thanks...

share|improve this question

2 Answers 2

No worries people! Found the solution by myself like all the time..

Following are steps to recover/fix your MBR in such case:

  1. Create Windows 7 Bootable USB Using Windows 7 USB/DVD Tool (link to download)
  2. Boot using this USB Disc
  3. When the setup shows partitions, press Shift+F10
  4. Type "bootrec /fixBoot", enter
  5. Type "bootrec /fixMbr", enter
  6. Restart and boot without USB, Enjoy!
share|improve this answer

In this case you have to fix your MBR. put your windows installation disc to you dvd rom and restart and boot your computer through Windows DVD and repair your OS. now then try to install Ubuntu Learn more about MBR

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.