Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a problem with my graphic card. When I try to enable desktop effects on Ubuntu 10.10, "Desktop effects could not be enabled" message appears.

I have Asus ul50vg (nvidia G210M). I don't use any xorg.conf file because when I generate it through nvidia-xconfig, only terminal appears after boot.

Do you have any idea how to solve that problem?

share|improve this question
    
Have you tried installing the official nVidia from their website? –  User Feb 20 '11 at 20:01
    
It causes the same problem. After installation of the driver from nvidia website, Ubuntu drops to terminal during booting. When I remove xorg.conf, it boots normally. Desktop effects, however, can not be enabled anyway. So, the situation is the same as with the Ubuntu nvidia driver. –  user11177 Feb 20 '11 at 20:53
    
When I try to run compiz from terminal, I get: Xlib: extension "GLX" missing on display ":0.0". compiz (core) - Fatal: Root visual is not a GL visual compiz (core) - Error: Failed to manage screen: 0 compiz (core) - Fatal: No manageable screens found on display :0.0 –  user11177 Feb 20 '11 at 21:22
1  
It seems to work now. I've changed IDE configuration in bios from Enhanced to Compatible. It's kind of weird because everything used to work with the Enhanced option. However, I think the problem is solved now. I would like to thank Shubh and Stephan for their answers. –  user11177 Feb 21 '11 at 22:08
2  
@MichalPavelka Can you pleas answer your own question with what you did to correct this? It's best do to so for future people needing assistance –  Marco Ceppi Apr 30 '11 at 12:07

2 Answers 2

This was fixed by the user by changing IDE mode from Enhanced to Compatible in the system BIOS.

share|improve this answer

Try to install bumblebee to have both the Intel and Nvidia cards working simultaneously: https://launchpad.net/~hybrid-graphics-linux

sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
# check the speed and compare to running:
glxgears
# If you have google-chrome installed, you can try it with/without optirun and report the FPS values on the mailing list:
optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.