Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Unable to install VBox Guest Additions in Ubuntu. It shows some problem woth Linux Header. PS: I am using ubuntu 12.10 guest on Windows8 Host. When I tried installing it I got following:-

Verifying archive integrity... All good.
Uncompressing VirtualBox 4.2.10 Guest Additions for Linux..........
VirtualBox Guest Additions installer
Removing installed version 4.2.10 of VirtualBox Guest Additions...
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
Installing the Window System drivers
Installing X.Org Server 1.13 modules ...done.
Setting up the Window System to use the Guest Additions ...done.
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components ...done.
Press Return to close this window...
share|improve this question
You need to install the linux-headers-generic package. For some reason, it's missing from the default install. – mikewhatever Mar 27 '13 at 2:29
Failed built of GA does not usually come from missing headers (which should have been installed by default btw). We need to know the exact error from vboxadd-install.log in the guest. – Takkat Mar 27 '13 at 7:34
@Vikramjeet: If someone's answer was helpful to you, then please consider marking it as the accepted answer so others may more easily find it in the future. This is also a polite way to thank the person answering your question for helping you out. – Danatela May 28 '14 at 4:19

In order to install VirtualBox Guest Additions successfully, you need the linux-headers-generic package, which can be found in the Software Center. If it doesn't show up after you type it in, click on the lower left corner where it says "Show Technical Items", then it should list it. Install the package.

Alternatively, you can go to the Ubuntu Packages site Here (For 64-Bit Ubuntu). If you have 32-Bit Ubuntu, go to this link Here. Regardless of which link you click, click on "quantal" and download the package. Double-Click on the downloaded package and install it.

Either way (once it is done), you can now install VirtualBox Guest Additions without a problem.

Hope this helps.

share|improve this answer

If you're on a debian-based distro and you're a neckbeard like most of us using linux, you can also just open a terminal window and type:

(sudo) apt-get install linux-headers-generic

I did it this way because it wasn't showing up in the software center for whatever reason (and I couldn't find the Show Technical Items option that Vikramjeet mentioned.

share|improve this answer

I had a similar problem on Ubuntu 14.04 Desktop with VirtualBox 4.3.10.

When I run ls -al /sbin/mount* it shows that /sbin/mount.vboxsf is a symlink to /usr/lib/VBoxGuestAdditions/mount.vboxsf which does not exist. After poking around a bit, the VBoxGuestAdditions are installed at /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions/

sudo ln -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions /usr/lib/VBoxGuestAdditions

This fixed the shared folders for me

share|improve this answer
The problem is not with shared folders, it is with Guest Additions itself. – Danatela May 28 '14 at 4:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.