Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After asking here I deleted my entire ubuntu install and reinstalled xubuntu as per instructions here. I've partitioned 20gb root, 478gb home, 2gb swap, on sdb (a non-booting windowsXP is on sda). I installed xubuntu from liveCD onto sdb, which put grub on sda which is recommended for this exact situation by this post from this thread. My PC now doesn't boot - no grub menu, just a flashing underscore. I redid the install - deleting partitions and re-doing them, just to make sure it was putting grub on sda. I can boot to LiveCD and use as normal. Any idea what I should do?

Thanks in advance.

share|improve this question
    
Are you sure your bios isn't trying to boot from the external first? –  Scott Goodgame Mar 26 '13 at 22:14
    
the external hard drive, do you mean? or sda or sdb? –  dez93_2000 Mar 26 '13 at 22:18
    
removed external hard drive, no change, so assume you mean something else! BIOS is set to boot from HD, then CDROM, the USB. –  dez93_2000 Mar 26 '13 at 22:24
    
As I understand it, your internal hd is sda, and the external is sdb. have installed xubuntu (my choice also!) onto an external (sdb) and just want to boot, with grub on the internal(sda) to the xubuntu on sdb? –  Scott Goodgame Mar 26 '13 at 22:40
    
sorry if i wasn't clear. sda & sdb are both internal SATA 500gb drives. I'm wondering if there's some grub magic I can do or repair install grub or something... –  dez93_2000 Mar 26 '13 at 22:54

2 Answers 2

up vote 2 down vote accepted

Easy Way: Download this and run boot repair Boot-Repair-Disk

More Typing Way:

  1. Boot from live cd and go to a command prompt
  2. sudo grub-install /dev/sda
share|improve this answer
    
tried the latter. like before, it does "path '/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting." Someone suggested "modprobe dm-mod" them try again, but it didn't work. –  dez93_2000 Mar 26 '13 at 23:22
    
Would Boot-Repair-Disk do things any differently thus be more likely to work? –  dez93_2000 Mar 26 '13 at 23:25
    
I am guessing that you want to keep xp on sda, right? what if you just switch the data cables on the drives to switch them, then do the 'More Typing Way'? It should have xubuntu on it so it has a boot directory and the grub install should pick up your xp for you. –  Scott Goodgame Mar 26 '13 at 23:31
    
sexy idea. let's have a go. –  dez93_2000 Mar 26 '13 at 23:33
    
gave me an extra BIOS option called "LS120" but I chose hard drive instead, with CDROM as secondary as normal. Grub came up. Chose ubuntu. And now I'm running xubuntu for the first time. Goodgame - well played. –  dez93_2000 Mar 26 '13 at 23:43

If that worked for you, for future reference, change the boot order of your internal hdd within the BIOS instead of swapping cables. I had the same frustrating problem of installing Xubuntu into a fresh hdd, but kept the old one installed for a mirror drive. After running through the entire installation process, I tried to boot and got the grub rescue> prompt. I went into my BIOS settings, moved the new hard drive to the top, saved, and rebooted to a glorious blue desktop running Xubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.