Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm addicted to certain websites to the point where it's interfering with my life regularly and sick of it. I want to install website blockers that aren't easy to circumvent.

In Chrome, incognito mode is easily accessible with a ctrl-shift-n. That is ridiculous. Whenever I feel an urge to go on an addictive website, it doesn't matter what blockers and regulators I've got installed; three keys can get round them in a second.

Simply uninstalling chrome isn't an option either, as it's way too easy to sudo apt-get install it right back.

So yes, I want to disable incognito mode completely (and if possible making it totally impossible to get it back). I note that some guy has figured out how to do it on windows with a registry entry: http://wmwood.net/software/incognito-gone-get-rid-of-private-browsing/

If it can be done on windows it can be done on ubuntu!

share|improve this question
    
I want to install website blockers that aren't easy to circumvent. reminds me of askubuntu.com/questions/252210/… –  user25656 Mar 27 '13 at 3:05
add comment

marked as duplicate by jokerdino Oct 28 '13 at 18:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Form incognito main page:

Because Google Chrome does not control how extensions handle your personal data, all extensions have been disabled for incognito windows. You can reenable them individually in the extensions manager.

share|improve this answer
    
Note that this only replaces the ctrl-shift-n with a couple of menu clicks. I would accept this answer if it showed how to lock the settings down and throw away the key –  TheIronKnuckle Mar 26 '13 at 21:18
    
Note that it's impossible to lock down that setting. Disabling extensions by Ctrl-shift-n just gets replaced with a couple of menu clicks. If there was a way to also prevent this I'd accept your answer –  TheIronKnuckle Mar 26 '13 at 21:21
    
@TheIronKnuckle But i thought your problem was with incognito disabling the extensions ? –  Suhaib Mar 26 '13 at 22:46
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.