Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sometimes, after logging out and in, Xubuntu forgets the positions of the desktop icons and re-arranges them on top-left as default.

I have tried a proposed solution on a similar subject. This locks the icons that were on desktop when I ran the command but not the newer icons.

What could I do to permanently fix this issue? I use Xubuntu 12.10 with xfce 4.12.

share|improve this question
up vote 3 down vote accepted

The problem seems to have been solved in the 13.04 edition, but the "semi-solution" I had used made the problem persist. If you have the same problem, try deactivating the lock:

sudo chattr -i ~/.config/xfce4/desktop/icons*

share|improve this answer
    
For what it's worth, this just happened to me on Xubuntu 14.04, so if it was indeed fixed in 13.04, there's been a regression. – glibdud May 23 '14 at 16:51

There is a good solution on ubuntuforums from go4unkwn2: http://ubuntuforums.org/showthread.php?t=2232021

He wrote two scripts, one for backing up ~/.config/xfce4/desktop/icons* files, and second for writing them back from the backup.

I would just add a small enhancement - make an entry in /etc/lightdm/lightdm.conf to run the first script at xfce session end, so you don't have to run it manually every time you want to save icon positions: add or edit line:

session-cleanup-script=your_script_to_save_desktop_icons_position.sh

For restoring icon positions, you can run the second script at session startup, as go4unkwn2 suggests, by adding an entry in Settings/Session and Startup

share|improve this answer

I'm on Xubuntu 14.04 and I had no lightdm.conf file. I put the session-cleanup-script line in /etc/lightdm/lightdm.conf.d/10-xubuntu.conf and it worked but the logout process now takes a while.

share|improve this answer
    
Please share the instruction as well – Mostafa Ahangarha yesterday

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.