Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.10 on my Lenovo Thinkpad SL-510. The computer has been working for several weeks now with no problems.

Today when I turned the computer on I got a blank purple screen. Turning it on again (after a forced shutdown) I get to the grub screen. Selecting Ubuntu results in the following:

mount: mounting /dev/mapper/ubuntu-root on /root failed: Invalid argument

mount: mounting /dev on /root/dev failed: No such file or directory

mount: mounting /sys on /root/sys failed: No such file or directory

mount: mounting /proc on /root/proc failed: No such file or directory

Target filesystem doesn't have requested /sbin/init.

No init found. Try passing init= bootarg.

BusyBox v1.19.3 (Ubuntu 1:1.19.3-7ubuntu1.1) built-in shell (ash)

Enter 'help' for a list of built-in commands.

(initramfs)

I ran the memory test from grub and it returned no errors, but I still get this message when trying to load Ubuntu.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

you can try boot repair it may be helpful to you..

https://help.ubuntu.com/community/Boot-Repair

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Mar 26 '13 at 11:55
    
After running Boot-Repair, the system started normally. Thank you Jai for the speedy answer! –  Naveh Mar 26 '13 at 13:59
    
You are most welcome, still i would suggest back-up your data if any.. –  Jai Mar 27 '13 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.