Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Oracle 10g Express edition in Ubuntu 10.10 and it doesn't show or ask to give my password during installation.

When I click on "start database" it gave the warning "Operation failed, abhi is not a member of 'dba' group." and when clink on "Run SQL command line" it shows /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/nls_lang.sh: 114: [[: not found

When I click on "GOTO Database home page", it opens Mozilla's "Ubuntu Google search page".

Can anyone help me get my Oracle to work or tell me how to remove that because it is also not getting removed.
I tried all the commands that are given as suggestions by Ubuntu.

Please help me because I don't want to format my Ubuntu.

share|improve this question

2 Answers 2

For the: "/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/nls_lang.sh: 114: [[: not found"

The solution is to simply edit it (as root) and remove a pair of square brackets on lines #108 and #110.

Type:

sudo gedit /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/nls_lang.sh

Scroll down until you find this:

if [[ -n "$LC_ALL" ]]; then
locale=$LC_ALL
elif [[ -n "$LANG" ]]; then
locale=$LANG
else
locale=
fi

Then change it to this (remove a pair of brackets):

if [ -n "$LC_ALL" ]; then
locale=$LC_ALL
elif [ -n "$LANG" ]; then
locale=$LANG
else
locale=
fi

Then click SAVE. Now try this command again to set your environment variables:

/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/oracle_env.sh

Nothing appears to happen when you do it but, it auto-sets your variables. DONE!

Enjoy.

Thanks to this blog: http://beardedmagnum.com/2007/09/15/oracle-xe-on-ubuntu/

share|improve this answer

abhi don't worry ... all have solution ... ;)

Install for 32 bits is easy:

sudo sh -c "echo 'deb http://oss.oracle.com/debian unstable main non-free #Oracle XE' >> /etc/apt/sources.list.d/oraclexe.list"

wget http://oss.oracle.com/el4/RPM-GPG-KEY-oracle -O- | sudo apt-key add 

sudo apt-get update 

sudo apt-get install oracle-xe-universal

for 64 bits:

wget http://oss.oracle.com/debian/dists/unstable/main/binary-i386/libaio_0.3.104-1_i386.deb  http://oss.oracle.com/debian/dists/unstable/non-free/binary-i386/oracle-xe-universal_10.2.0.1-1.1_i386.deb

sudo dpkg -i --force-architecture libaio_0.3.104-1_i386.deb oracle-xe-universal_10.2.0.1-1.1_i386.deb 

rm libaio_0.3.104-1_i386.deb oracle-xe-universal_10.2.0.1-1.1_i386.deb

Remove :

You can use apt-get command to remove / delete Oracle express edition server from the Ubuntu Linux.

Open terminal.

Type the following command to delete it:

sudo apt-get remove oracle-xe or oracle-xe-universal

Configure :

follow this simple an well explain tutorial with screenshot .. it is say how to add your user to dba groups and how to configure oracle to give you a password..

start in step 1. Configuring Oracle

how-to-setup-oracle-10g-xe-in-ubuntu.html

P.D :

About the error ....

you may get an nls_lang error as follows when you try to export the environment variables.

Solution:

ubuntu uses a BASH linux shell. Now open “nls_lang.sh” with a text editor and set the correct shell parameter in the first line of the script.

see step 5. open nls_lang.sh.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.