Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried a number of clients now including Kopete, Pidgin and Empathy but none of them seem to respect my proxy settings. For example in Pidgin after adding a yahoo account then setting:

Proxy type: HTTP
Port: 8080

(I'm going to be going through Privoxy) in the Proxy tab then clicking Use account proxy for HTTP and HTTPS connections in the Advanced tab.

All I get is

Unable to connect: Server closed the connection

from Pidgin.

Everything works fine if I flush iptables of course, but I obviously don't want to do that.

How can I get at least one of these clients to work with Yahoo IM and through a proxy (local Privoxy)?


I discovered it was actually Dansguardian that was killing Pidgin since the blanket block SSL and blanket block IP address only were on and it seems Pidgin connect via some address like https://66.196.120.xx:5050 each time.


This allowance in Dansguardian also fixes the problems with telepathy too and it also now connects and seems to respect the system/environmental proxy settings. Just Kopete then that is broken..

share|improve this question
So does it work now? Could you clarify on that? – MiJyn Mar 26 '13 at 6:12
@MiJyn Pidgin works now yes if I allow SSL tunneling from IPs in Dansguardian. The other clients Kopete and telepathy do not work for me though, they seem to simply ignore the system proxy regardless of whether I set it in ~.pam_environement , /etc/environment or in the system network settings. Thus they try to connect through the iptables blocked ports 80, 443 rather than using dansguardian and privoxy on port 8080. Although lsof -i -n -P does show Kopete to have established a connection on 5050 it forever says connecting on the prog itself, until I flush iptables. – fpghost Mar 27 '13 at 1:29
When I first try to connect to my Yahoo account through Kopete lsof -i -n -P shows kio_http 4845 _myusername_ 9u IPv4 86989 0t0 TCP> (SYN_SENT) too, I have no idea what this is but it is clearly associated with Kopete and still trying to go through 443 despite the environment proxy settings. – fpghost Mar 27 '13 at 1:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.