Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I cannot install ia32 libs no matter how hard I try. Here is the error I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch but it is not installable
E: Unable to correct problems, you have held broken packages.

When I try to install ia32-libs-multiarch i get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs-multiarch is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ia32-libs-multiarch' has no installation candidate

I've tried many things suggested on forums. Is this not fixable or is there a certain fix I may not have already tried?

share|improve this question

marked as duplicate by jokerdino Apr 3 '13 at 10:20

This question was marked as an exact duplicate of an existing question.

Before saying don't point me to a forum post that doesn't work, you should list the ones you've tried. I'm sure the solution is already posted somewhere and denying all forum posts doesn't help. – RobotHumans Mar 26 '13 at 1:33
can you show us your software sources? I'm getting the feeling that the problem is there. – Jason Mar 26 '13 at 4:09

Sounds like your APT doesn't have an i386 foreign architecture. I have no idea why this happens to people...


sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs
share|improve this answer
Thanks a lot! This helped me. – ubuntuuser897675 Mar 29 '13 at 17:51
@ubuntuuser897675: Then please mark the answer as accepted. – tumbleweed Mar 30 '13 at 19:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.