Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Kubuntu 12.04 with an AMD/ATI graphics card (and multiple monitors). After a system update about a month or two ago KSnapshot stopped working for me. All it does is capture the stock KDE desktop background (even though that isn't what I see on the screen). I cannot actually capture any application windows or any type of useful content. The screen capture feature of Gimp exhibits the same error.

The appearance of this error coincides with a Kubuntu system update (approx a month or so ago) that changed the lockscreen behavior. It appears to be a security related change. I don't know the details (or even where to find the details) of the update. But the first update was buggy and it was follow closely by another one. Both affected the lockscreen. The first update broke KSnapshot -- and monitor power management when the desktop is locked. The follow up fixed the monitor power management issue, but it did not fix the ability to capture a screen shot.

The end result for me appears to be a more secure lock screen but broken KSnapshot.

I have been waiting patiently, but I think now is the time to be proactive after waiting more than a month. I am trying to learn anything related to this issue. Google has not helped.

share|improve this question
    
I'm actually having this exact same issue. This is the only result I've found on google. It's only intermittent for me though. I have a very similar setup as well. AMD proprietary drivers running 3 monitors. –  Falmarri Apr 6 '13 at 16:29

1 Answer 1

up vote 0 down vote accepted

Questions/ Check list

AMD with the open/propietary drivers ? Driver version ?

KDE version ? (available KDE 4.8.5 & 4.10.1)

Any error messages ? Have you tried to launch the ksnapshot from the konsole/terminal ?

Ksnapshot help:

:~$ ksnapshot --help
Usage: ksnapshot [Qt-options] [KDE-options] [options] 

KDE Screenshot Utility

Generic options:
  --help                    Show help about options
  --help-qt                 Show Qt specific options
  --help-kde                Show KDE specific options
  --help-all                Show all options
  --author                  Show author information
  -v, --version             Show version information
  --license                 Show license information
  --                        End of options

Options:
  -c, --current             Captures the window under the mouse on startup (instead of the deskto
  --fullscreen              Captures the desktop
  --region                  Captures a region
  --freeregion              Captures a free region (not rectangular)
  --child                   Captures a part of windows

Are there error messages in the ~/.xsession-errors ? About error messages: http://www.kubuntuforums.net/showthread.php?59067-Where-are-error-messages-from-programs-launched-from-the-K-menu

Have you tried with the new user ? Sometimes the KDE settings get screwed - with the new user they should work. If they are working with the new user then you could reset the old users settings.

share|improve this answer
    
I have the latest version of everything except the proprietary ATI/AMD driver. Unfortunately, there is no simple upgrade for that driver. One must uninstall it and reinstall the newer version. Given the fact that installing it to start with was a huge PITA, I cannot risk altering my system at this time. I depend on my system for day to day work. I guess I will have to live without a screen capture solution because there is no way I can afford the time once again to go through the hassle I went through to get my 3-monitor system working initially. –  MountainX Apr 10 '13 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.