Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I checked the Keys in Eclipse, Shortcuts in Settings, Autokey doesn't seem to interfere, I'm not sure where else to look for.

How can I trace and fix Ctrl+Space for eclipse?

share|improve this question

marked as duplicate by Eliah Kagan, Luis Alvarado Apr 7 '13 at 21:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What are you waiting when you press that shortcut? In other words, what do you mean with it doesn't work. –  Lucio Mar 25 '13 at 22:06
    
Auto-completion (Content Assist), I've also tried enabling and disabling all kind of stuff in the settings section for CA, I think CTRL+Space not making CA pop up doesn't have to do with it's settings. –  mirandalol Mar 25 '13 at 22:08

1 Answer 1

This can be caused by a number of different things.

For one, you might consider creating a new workspace and copy the old files into the new one. This has worked for others. Just remember to check the “Copy projects into workspace” when you import.

Another cause could be a wrong configuration in Eclipse. Go to
Preferences --> Java --> Editor --> Content Assist --> Advanced. Here you have to make sure “Other Java Proposals” is ticked.

It could also very well be another applications using the same shortcut which are conflicting with Eclipse. There are no such applications installed by default on Ubuntu though, but it you are using apps such as GNOME-DO (which i believe uses CTRL + SPACE) that might be your problem.

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Provide possibly an abridged version of the content here to help create a higher quality answer –  Lucio Mar 25 '13 at 23:02
    
Also, in this site we don't like those answer with google that, google this. Because their show no effort to help, and sometimes are 100% not useful. So, take a time, and modify your answer. –  Lucio Mar 25 '13 at 23:04
1  
[I had ibus enabled accidently](askubuntu.com/questions/243639/… ), This answer helped me resolve my problem, thanks everyone for their time. –  mirandalol Mar 26 '13 at 7:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.