Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having this problem since maybe 4, 5 months ago. I've search in the forums and tried every given solution. Please help.

I have an ASUS G73JH with an ATI Mobility Radeon HD5870 Graphic Card. The GPU idle temperature is around 95°C, but after some time of use it rises over 100°C after some time of use (even using a fan base). It rises quicker when watching videos, achieving even 110°C.

I've tried:

  • Fresh install of ubuntu 12.04, 12.10, even 13.04
  • Using default drivers, or property drivers (both fgrlx and fglrx-updates) (Catalyst 9.00, 9.01, 12.100)
  • Using every kernel since 3.5 to 3.8
  • Downgrading xorg xserver from 1.13. to 1.12
  • Using the Jupiter power manager applet
  • Modifying the grub (Modifying this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash " for this one GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 pcie_aspm=force")

However, for sure i'm missing something. My father has the same machine working with temperatures around 82°C. He did change too many things that he doesn't remember which made it work. Does someone has the same machine or at least the same Graphic Card working perfectly?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Couple of checks you need to do:

Eliminate Hardware Issues : - Using Windows and latest drivers, does your GPU shows normal temperatures. - Is the laptop fan and vents free of dirt and lint. If not, get it services or using a air blower clean them. (http://www.youtube.com/watch?v=T0BQ6YUFaoY) - Are you using proper thermal paste on the GPU. Arctic silver etc. are known good ones. Please get this done from a service center.

Use the proper ATI drivers - At the ATI site, download the latest driver for your card and the architecture (64 bit / 32 bit) and check for temepratures. - Use the open source driver from the Ubuntu built in drivers.

Switch to low graphics mode - At Ubuntu login, use the Ubuntu 2D option (if available)

Graphics intensive programs - Do not load any graphics intensive prorgrams - games etc. on this machine. - Reinstall compiz. (sudo apt-get --reinstall compiz)

Switch to other Distro - Debian is the best option. Very stable.

Let us know.

Best Regards,

Gurmeet Arora

.

share|improve this answer

It is solved now. I needed to clean the fans. I still can't believe the temperature rised so high because of that.

Thanks for the help and support.

share|improve this answer
    
Can I ask why you marked your own answer as the correct answer when Gurmeet's answer said to do just this? –  fossfreedom Oct 9 '13 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.