Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I'm trying to troubleshoot this and am following these instructions to help me out.

I'm getting a black screen after suspend and am using a Toshiba NB515-SP020LL with a GMA3600 graphics card. It has the latest BIOS. I am running 12.04

The graphics card isn't supported yet so I'm sure the problem is related to that. I don't mind since this is a netbook and high performance is not a priority. It'd just be nice to suspend the computer. :)

Any suggestions?

cat /proc/acpi/wakeup > wakeup

Device  S-state   Status   Sysfs node
ELAN      S4    *disabled  
USB0      S3    *enabled   pci:0000:00:1d.0
USB1      S3    *enabled   pci:0000:00:1d.1
USB2      S3    *enabled   pci:0000:00:1d.2
USB3      S3    *enabled   pci:0000:00:1d.3
USB7      S3    *enabled   pci:0000:00:1d.7
RP01      S4    *disabled  pci:0000:00:1c.0
PXSX      S4    *enabled   pci:0000:01:00.0
RP02      S4    *disabled  pci:0000:00:1c.1
PXSX      S4    *disabled  pci:0000:02:00.0
RP03      S4    *disabled  
PXSX      S4    *disabled  
RP04      S4    *disabled  
PXSX      S4    *disabled  
LID0      S4    *enabled
share|improve this question
    
You could try this. –  mikewhatever Mar 26 '13 at 8:16
    
thanks! that specific suggestion didn't work but reading the pm-suspend man page is illuminating... –  azoe Mar 26 '13 at 12:01
    
Hm..., to be honest, that didn't work on my netbook with GMA500 either. I had to do sudo mv /usr/lib/pm-utils/sleep.d/99video /usr/lib/pm-utils/99video, to solve exactly the same issue. –  mikewhatever Mar 27 '13 at 0:06
    
@mikewhatever I recommend posting that as an answer. Even if it's not what solved the OP's problem here, this is the best place to post it, isn't it? –  Eliah Kagan Mar 29 '13 at 1:44
add comment

1 Answer

To simply get suspend to work on this system I just added this line to the /etc/pm/config.d/gma500 configuration file:

ADD_PARAMETERS='--quirk-s3-mode' 

I didn't have the file, or any other in that directory, so I created it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.