Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have somehow set Ctrl+F to open xterm Terminal (not my default).

I tried finding the configuration in dconf, but I didn't find anything mentioning keyboard shortcuts, except one custom column with "command1" to some number, but it didn't have anything with Ctrl+F.

How do I change back?

share|improve this question
    
Go to System preferences -> Keyboard -> Shortcuts and find it there. –  Lucio Mar 25 '13 at 19:28
3  
Have you got xbindkeys installed, as ctrl + f is one of the defaults enabled in ~/.xbindkeysrc that can conflict with your other keyboard shortcuts. –  user76204 Mar 25 '13 at 19:29
    
@Mik I'd add that as an answer :-) –  Seth Mar 25 '13 at 19:41
    
@Seth Done. This is the most likely cause I should think, considering it is specifically the ctrl+f shortcut. –  user76204 Mar 25 '13 at 19:44

1 Answer 1

up vote 9 down vote accepted

If you have xbindkeys installed, Ctrl+F is one of the default shortcuts enabled that launches xterm. It can, however, conflict with your other custom keyboard shortcuts.

To deactivate the shortcut, edit your ~/.xbindkeysrc and comment out the shortcut so it looks like this:

# set directly keycode (here control + f with my keyboard)
#"xterm"
#  c:41 + m:0x4

Now, this setting will not be read until xbindkeys restarts, so run killall xbindkeys and then xbindkeys & if you want to restart it. Alternatively, you can just logout and login again.

share|improve this answer
    
YES! It bugged me for days! I installed xbindkeys to help someone here and totally forgot about it. Thank you VERY much. –  mirandalol Mar 25 '13 at 21:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.