Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Environment : Lucid Lynx (Ubuntu 10.04)

I had installed VLC 1.0.6 using the following:

% sudo add-apt-repository ppa:lucid-bleed/ppa
% sudo apt-get update
% sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc

After a month or so, While updating via command line, I got a notification stating a lot of packages were automatically installed and hence I should uses apt-get --autoremove which I used. Now VLC was uninstalled in this. And now when I try to install VLC back, I getting the following error:

root@srihari-laptop:~# apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  vlc: Depends: vlc-nox (= 1.1.13-1~ppa1~lucid1) but it is not going to be installed
   Recommends: vlc-plugin-notify (= 1.1.13-1~ppa1~lucid1) but it is not going to be installed
   Recommends: vlc-plugin-pulse (= 1.1.13-1~ppa1~lucid1) but it is not going to be installed
E: Broken packages

I have tried to do every thing possible including purging the packages but that didn't work out. I need VLC to work. Please let me know how do I fix this.

share|improve this question
2  
Ubuntu 10.04 reached it's EOL (End of life) soon ago. I would consider upgrading. In fact, this error has probaly happend because of the version is so old. –  nerof61 Mar 25 '13 at 16:18
    
I use ZTE Communications' Data Card that works with Reliance service. The problem is this device installs it's own network software and is not controlled by the ubuntu network manager. Now the binary package auto stored in this device works fine with Lucid but shows errors with precise. –  Srihari Mar 25 '13 at 16:42
    
@nerof61 I don't see why this would happen because it's so old--it hasn't reached EoL yet. At the end of this month, 10.04 will be EoL for desktop use. (I certainly agree that anyone running 10.04 on the desktop should upgrade. But being near end-of-life doesn't break anything.) –  Eliah Kagan Mar 25 '13 at 17:36
add comment

1 Answer

up vote 0 down vote accepted

Try with this PPA: https://launchpad.net/~nvidia-vdpau/+archive/cutting-edge-multimedia/+packages

It provides VLC and FFMPEG, so dependencies should work. Of course, remove the other PPA.

share|improve this answer
    
Synaptic doesn't show that any package is broken at all. This error comes up when I install using command line. While installing vlc via Synaptic, I get a dependency error that vlc-nox will not be installed. If I try to install vlc-nox first, then I get libavformat52 which in turn gives me libavcodec52 which in turn asks libavcodec52 >= 1.0.6 but installed version is 1.0.4 –  Srihari Mar 25 '13 at 16:47
    
E: Broken packages -> that is why I was thinking about broken packages. –  ttoine Mar 25 '13 at 16:49
    
Srihari, can you tell me if it works with this PPA? –  ttoine Mar 25 '13 at 17:22
    
Ttoine, thanks that worked. I removed the ffmpeg and vlc ppas(launchpad.net/~jon-severinsson/+archive/ffmpeg) (launchpad.net/~lucid-bleed/+archive/ppa) and uninstalled libavformat52 v 1.0.6. After I reloaded, I got the right versions for everything. And then vlc install worked. –  Srihari Mar 26 '13 at 1:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.