Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new installation of Ubuntu Server 12.04 LTS. Running the test of python-scipy failed to go through and stopped as the display below.

scipy.test()
Running unit tests for scipy
NumPy version 1.6.1
NumPy is installed in /usr/lib/python2.7/dist-packages/numpy
SciPy version 0.9.0
SciPy is installed in /usr/lib/python2.7/dist-packages/scipy
Python version 2.7.3 (default, Aug  1 2012, 05:14:39) [GCC 4.6.3]
nose version 1.1.2
This happens to my another installation of Xubuntu 12.04 as well. How can I get the problem resolved?

Thanks in advance.


Update: It is related to autofs. Removing autofs resolved the issue.

share|improve this question
    
Could you post your solution with some more detail in an answer and accept it? This will help future users experiencing a similar problem. –  Kevin Bowen Mar 28 '13 at 0:07

2 Answers 2

This answer is in response to maggotbrain's request of posing the solution as an answer.

Solution: remove autofs using the aptitude tool

For previously mounted FS using autofs, you can use soft link or 'mount --bind' for local folders, or configure /etc/fstab for network drives.

share|improve this answer

I've just tested scipy.test() on my vps running Ubuntu 12.04 Server. I install numpy, scipy, nose via apt.I run the test from a Python console. The test failed but that's another issue. See my scipy.test() output. How do you run the test? I guess it was running, somehow you just didn't see the output.

share|improve this answer
    
Thanks for the reply. My further tests just revealed that the issue was related to autofs mount as well, even though I have no idea why autofs is causing this. I removed autofs and this problem got resolved automatically. scipy.test() can run now, with exactly the same error message as your output. And I got the same output from several of my Ubuntu installations. –  slacktty Mar 25 '13 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.