Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have accidentally clicked on "hide this notification" / "Do not show this message again" button in OSD notification system in Lubuntu 12.10, namely xfce4-notifyd. The information was about wireless network being connected (I still have notification of being disconnected from WiFi) from network applet.

I can configure style of notification with xfce4-notifyd-config, how to configure which notifications are shown and which are not?

share|improve this question
I have found some answer on Ubuntu forum about the same issue for gnome-power-manager, but the solution doesn't work for my issue: – Jakub Narębski Mar 26 '13 at 8:25

As I disable the vpn notification, I found the solution prompted by this thread. Open gconf-editor, expand apps, expand nm-applet, you will see the entry of 'disable-vpn-notifications'. Modify the value to undo it.

share|improve this answer

Warning: this answer is speculative because I haven't hidden any notifications myself!

Run find ~/ -mmin -10 -type f replacing -10 with a more appropriate time to specify how far back find should go (from the current time).

Depending on how active you've been, you'll get a list of files modified in the period you specified.

To find which file is modified by changing settings in xfce4-notifyd-config, I made a simple change, moving the location of the notification from bottom left to bottom right.

I then ran the find command given above. This let me identify ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-notifyd.xml as the file in which at least some settings of xfce4-notifyd-config are stored.

I hope you can find information in that file that may let you undo the "hidden" setting. To comment out stuff in .xml files use <!-- to denote the start of a comment and --> for the end. In other words, first back up xfce4-notifyd.xml and then edit the original to comment out any line (or content) that seems to be responsible for the "hidden" setting.

As I cautioned at the beginning, this is just a suggestion and not a proven means of reversing the "hidden" setting!

For the record, here's what my xfce4-notifyd.xml file looks like:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-notifyd" version="1.0">
  <property name="notify-location" type="uint" value="3"/>
  <property name="initial-opacity" type="double" value="0.580000"/>
  <property name="expire-timeout" type="int" value="5"/>
share|improve this answer
No, this file only shows settings for theme (i.e. visual style of xfce4-notifyd notification). – Jakub Narębski Mar 25 '13 at 15:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.