Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

cairo-dock visual performance is poor in lubuntu. My desktop suffers with black background when I navigate my mouse pointer on Cairo dock.

What is causing this and how can I fix it?

share|improve this question
    
You need to turn on the composite. It's handled by your Window Manager (metacity, compiz, xfwm, etc) –  user143311 Mar 25 '13 at 15:58
    
Although fabounet is correct about compisiting, if your running lubuntu in the first place you are likely to be speed/memory constrained. Have you looked at AWN ? It's really light. –  Scott Goodgame Mar 25 '13 at 17:22
    
there is also a Cairo Dock setting: System > Composition > "emulate composition with fake transparency" that might work, depending on your system/version. @fabounet would know better than I would though. –  drammock Mar 26 '13 at 0:31
add comment

1 Answer 1

Use a seperate lightweight compositor: xcompmgr (or use a heavyweight like compiz)

Install:

sudo apt-get install xcompmgr

Run it just once (until you logout):

xcompmgr -n

Or have it started automatically by adding it in the systemwide startup:

/etc/xdg/lxsession/Lubuntu/autostart

Or create a desktop icon for it and add this to your desktop session startup:

~/.config/autostart

(last option makes it very easy to turn it on or off via Desktop Session Settings )

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.